Problem restoring wallet

Before the latest update, I created a wallet, put some “testing” money in it and tried to delete the wallet and restore it before I transfer the rest from the exchange.
I then had the synchronise problem that I could not solve.

Now with the new update, the program synchronise fine, but when I try to restore my wallet I get the message “Wallet you are trying to restore already exists”.

So I tried to create another test wallet and delete it and restore it again from the 12 word phrase. and this time it says "Wallet restoration is in progress: 0% (1 week, 5 days, 10 hours, 11 minutes, 56 seconds)…

I mean come on!! wtf??
The basic request from a wallet is to be able to delete and restore it!

And one more thing: I know that daedalus wallet is storing temporary files on my computer because when I delete it and reinstall it, the synchronization with the network doesn’t start from zero. and my guess is that this is the reason it doesn’t let me restore the first wallet.

  1. Close Daedalus
  2. Delete directory %appdata%\Daedalus completely
  3. Start Daedalus again and restore your wallets

It shows “1 week” for a couple of first seconds while approximating the actual time and then gets changed to like minutes, or worst case - hours. In the latest version my wallet restored in ~ 30 minutes on my old laptop.

It does all of this.

Thanks for the reply.

I don’t have a directory or a file on my computer that contains both the words “appdata” and “daedalus” (windows 10)

Now the second wallet is at 18% after few hours, 12 hours estimation.
Is your old laptop for sale?

%appdata% is a special “magic” name in windows that points to the


directory. It’s hidden so hard to find manually. You can access it by opening an Exporer and entering %appdata% in the addressbar at the top and hitting “enter”. It should open the “Roaming” directory and there will be the Daedalus directory.

:slight_smile: Unfortunately no - but I also suspect the difference between HDD or SSD might play a big role (especially if HDD is significantly fragmented under windows). I have a full SSD, so it get processed faster. But it’s just my speculation.

Problem solved!!

Deleting those files KILLED my computer.
So I bought an SSD, installed it instead of my hard drive in my laptop, went back to win 7,
installed daedalus wallet, and walla!
My ADA acount was there.

When o’ when will the light node client be avalable?

1 Like

Damn, with twists like this you oughta be a Hollywood screenwriter :slight_smile:

Glad to hear everything turned out ok, tho! :+1:

Well, Ledger is expected somewhere in July, and they are preparing a lot of features required for it that are also will allow light-clients, so hopefully we’re gonna get some maybe this fall (-ish) :slight_smile:

1 Like