Daedalus - Restore Wallet Bug

daedalus

#1

Wanted to test the restore function of the Daedalus Wallet so I created a new wallet and transferred 10 ADA into it.
Then I deleted the wallet and attempted to restore it using the recovery phrase. The process appeared to be stuck (with the waiting indicator continuously spinning) for about 30 mins. I then tried closing the Daedalus wallet and opening it again to retry the restore but this time when i hit the “Restore wallet” button with the recovery phrase it returned an error message in red saying “Wallet you are trying to restore already exists.” But on my wallet list it’s not there.

Tried closing Daedalus and restoring the wallet a few more times with the same result. The wallet is not on my wallet list, nor am I able to restore it via the restore wallet feature.


#2

[Update] the restored wallet just popped up on the wallets list. so for anyone else who runs into this “Wallet you are trying to restore already exists” error, it seems the wallet list will update by itself in the background and should eventually show the missing wallet.


#3

I’m having the same issue. Restore wallet froze with the waiting indicator taking > 30 mins.


#4

I have been trying to restore my wallet as well but I can’t even pass the “Connecting to network” phase now. When I tried restoring the first time, nothing was happening then I decided to close it and reopen it and now it’s stuck on the network message phase. This sucks :frowning:


#5

Did you guys get your wallets restored? For me it popped up on the list by itself after a while when I force closed the application, reopened it and got the “Wallet you are trying to restore already exists” error.


#6

Yeah it worked for me after being stuck in the connecting to network message for nearly an hour. Guess it was just getting things done in the background… But the restore option worked for me yes and all the coins I had in the wallet were kept intact! :slight_smile:

Guess there are just some small bugs that need to be fixed but other than that, the wallet’s functions seem to work as intended!


#7

Hello community,
I would also like to add that I have had nothing but headaches using the Daedalus wallet for the past few weeks. I too have been getting the “Wallet you are trying to restore already exists” message and the “Connecting to network” freezing screen. I must say that it makes me worried that there are still serious bugs effecting the wallet at this stage. Hopefully they will be squashed soon. Is there anything I can do to help this help speed up this process? (send a log file or something) I would love to help.


#8

Hey, I’m not sure about that but maybe you could contact support? Haven’t tried it yet since I managed to solve my issues but perhaps they might help!


#9

Hi @Chopin

The dev team is aware of these issues and is working to fix them.
If you would still like to raise a support ticket, you can do so on this site: https://daedaluswallet.io/faq/


#10

Thanks, I have contacted support.


#11

According to FAQ Daedalus
"This is not a bug, it is actually trying fetch whole transaction history. The reason why it takes such a long time is because it is traversing through the whole blockchain to get the wallet synced."

How about to put a message on the GUI informing the user about that. In terms of UX making an hourglass circling undefinitly is a not good practice!!


#12

I too have the same issue. I have now reloaded Daedalus. It loads very quick but shows a zero balance. I have raised a support ticket also as I cannot get passed the message “Wallet you are trying to restore already exists”. To what i see the wallet just sits there & does nothing with a zero balance. I also did password protect my wallet on initial setup so my ADA should be safe. I hope they can fix it for me. or do you guys have another idea? Thanks everyone


#13

I have same issue, restoring the wallet I am stuck on the “restore wallet” screen with the little circle thingy going. there is no other indication that the program is doing anything except the disc lite access on my computer. I am assuming that to restore the wallet it has to re-process the whole block chain. this took a whole day the first time.


#14

UPDATE: after letting run for some time it finished re-sync the blocks and came up ok. but there was no feed back on what it was doing.

UPDATE: windows defender and/or the windows firewall and application checker is causing some kind of problem with the wallet. if they are on then the wallet goes into connecting to the network forever mode.

the current wallet is a full node type wallet and it has no business running on desktop versions of windows or mac. it should be for the server versions of windows at least.

Best practice should be only LINUX/Open source so the OS code can be pier reviewed - checked for backdoor code added at the strong request of governments.

you need a client version for windows, mac, android, and iphones. the non-geeky people are not going to wait 6 hours for the wallet to sync and with no feed back everyone thinks the application has locked up.


#15

Solution…

https://www.reddit.com/user/viv1kk