Changing stake pools question

I really hate my Ledger S…it is always saying transaction failed. I am trying to switch staking pools with my Daedalus and my Nano Ledger S is attached to it. I choose the new pool. It says delegate wallet. I hit continue. I select Ledger Nano S (has the pool im in printed in green on the left). I hit continue. Then it says currently selected stake pool, which is the new one. Kind of greyed out it has the old stake pool I’m currently in. Then I click continue again. Then it is charging me a .179845 fee, and it always says transaction confirmation failed. My ledger always says waiting for commands. I’ve tried rebooting…restarting my ledger etc…

What am I doing wrong…It’s like this ledger is impossible to use and I’m considering just going to the desktop daedalus ap which isn’t nearly as secure from what I’ve read…

Can anyone help? It really shouldn’t be this hard to switch pools.

Have you checked firmware/app versions?
I use ADALite.io with Nano S/X

I just updated to the new daedelus version and I had to update my ADALite on my Ledger as well. The 1 thing I wonder is if my USB ports are outdated or something…I only have 2 and have to keep sharing with other things…I’m considering getting a Cardano only laptop and see if that helps…getting tired of struggling so much with the fee payments and transfers…it’s already nerve racking enough without it always having problems since it’s alot of dollars sometimes.

I check with my ledger live program and everything is up to date. The best I can get is connect your Ledger and enter the pin. It is already connected and pin is already in…So I disconnect the ledger to try again and all of Daedelus closes out and I have to restart it. Then it just gets stuck on connecting to network like it’s all screwed up. Would it be worth reinstalling my Daedelus or is there some fix I could try? I even turned of my malware bytes and my surfshark is off…I’m not turning off windows protection that is just asking for trouble.

Sorry, I don’t know - a million things can go wrong with these USB connections. Make sure, the Ledger only ever has one client (i.e. close LedgerLive), then close all other programs as well (only for good measure). I use ADALite.io on Brave, Firefox or Chrome works for me as well (MacOS). They have a few connection methods, I only ever used “Default”

image

Daedalus is a full node wallet meaning it downloads and syncs the entire blockchain onto your computer. This requires lots of RAM. I recommend at least 16GB because the Cardano chain is already at 8-9 GB and growing. All other programs will be competing and swapping for RAM in your computer. This is the most common way computer programs glitch.

ADAlite.io is a web-based wallet meaning the blockchain is synced on their web servers and does not have the same memory requirements on your computer or smartphone. Adalite synced with a Trezor or Ledger hardware wallet is the best way to go in my opinion.

Neah… use yoroi wallet; is the best light wallet provided by Emurgo

I am using on my phone since 2018-2019 and no issues since then

1 Like

I downloaded ADALite thru Ledger Live program. It is the current version too, I just updated it a week or so ago. I did go thru and close my malwarebytes and everything that was running…Not the internet but I guess I could close those too in case…I use Firefox…I’m not sure where you are seeing the Default menu…I just plug in my Ledger, put in the pin and then go to Daedalus to do what I need…and I do open the Cardano app on my Ledger, but it always goes back to the menu and I have to open the Cardano app over and over until it says waiting for commands on the Ledger…then in Daedalus it says transaction failed or please connect your ledger and enter the pin…I am thinking about trying to transfer ada to a friend to see if it will even let me do that…but switch stake pools seems to be impossible at this point. I’m scared about buying more ada and not being able to move to to my Ledger…it’s just too hard to use this device…I hope I can one day find a better one.

Ya I have a beast of a PC…32Gb ram…and it’s an I7 so it’s overkill because I am a gamer. I just reinstalled Daedalus again and I put it on the Solid state drive in case that helps too. I have ADAlite downloaded to my Ledger from my ledger live program. I get out of the program once I’ve checked that in case it interferes.

Okay I found this website you were talking about…I never used ADAlite I guess…I tried to open it but it says “TransportError: Failed to sign with Ledger device: U2F OTHER_ERROR. Make sure other apps (e.g. Ledger Live) or websites interacting with your HW wallet are closed. Also make sure to use the latest available version of the Cardano app/firmware on your HW wallet and web browser.” I had to touch my Yubikey for some reason even tho that’s only for Coinbase. I’ve never used this program does it need to be installed to my Ledger, or is it just for the desktop…I’ll take any new program that works! Haha

Okay nevermind…I found a decent walkthru. Now I have Adalite on my pc and I can see my Wallet balance and everything…(scary)…I thought I had to use Daedalus for this info. Going thru the menu of this app, it looks like I won’t need to use Daedalus if I use this…Geez I’m noob as you can probably see…

I noticed there is a rewards account balance…I never saw this info on Daedalus…where did those ada come from? I even see a transaction called reward withdrawal…it looks like it’s a list of my staking rewards or something…Daedalus just gives me a lump sum total with no history of transactions, so I have been typing them into a spreadsheet to figure out how much I get each Epoch…

I think I will hold off switching pools until I figure out if there is a mistake in how many rewards I got and I actually received more than 3% which I thought was really low for 4 Epochs in a row.

Thanks for showing me this app I feel like this will be much easier to use than Daedalus!

One more question. I registered to vote on Daedelus. Can I move my registration to AdaLite, or do I have to pay another fee to register there too? They just barely added Ledger voting so I can finally see how that works hehe.

Thanks so much for all the help!