I’m desperate. Can’t stake my ADA on Daedalus wallet

I’m desperate. Can’t stake my ADA. Looked in the forum, looked in Reddit and it seems like I’m doing everything right, but… I want to stake on Ledger S hard wallet through Daedalus. Yes, I’ve installed Cardano’s newest version on Ledger Live, send my tokens to Yoroi, and later on to Daedalus. It shows the amount, everything seems fine. But when I choose stake pool it asks to connect hard wallet and enter a pin, I do that, wallet loads up, but nothing happens (no push notifications nothing) and Daedalus just shows loading icon until Ledger wallet turns off alter 10+ min. Second, if I try to connect Ledger, enter pin and stake to staking pool it just writes “Transaction confirmation failed”.

Hi @Noaka, that is annoying!

You are sure you have the newest firmware of ledger installed?
If yes, try going to yoroi wallet, left top of screen select “back to wallets” > “add new wallet” (right top) > “connect to hardware wallet” and now connect to your ledger.
If this is done you should see you balance. Now try to stake using yoroi. It doesnt matter if you stake with yoroi or daedalus. How does this work out?

2 Likes

Agreed with ADA4Good. It doesn’t matter if you stake with Yoroi or Daedalus. In this case, I’d probably prefer Yoroi to be honest.

For Daedalus, there’s a chance the daedalus wallet hasn’t fully synced to the blockchain so it’s not “ready” yet. Yoroi is a “light” wallet so won’t have that problem.

CPX Pool

2 Likes

Thanks for your time. Just tried that. Other kind of problem. After connecting Nano S and entering PIN etc. Yoroi shows “Something unexpected happened. Please retry.” Tried several times. Later it showed that it’s already paired. But overall - same problem.
P.S. And my coins on Daedalus is kind of “stuck”, can’t send them to Yoroi nor exchange.
P.S.S. Just tried different approach. Send new ADA’s to Yoroi from an exchange and delegaled without any problems. But it doesn’t solve my “stuck” ADA’s on Daedalus. And sadly, it’s majority of them…

[SOLVED] Tried different approach. “Daedalus” still not working with the hard wallet (at least for me), but I managed overcome my problem through “AdaLite” hard wallet. Just had to turn on my Ledger and Cardano app on “Waiting for commands…”, then connect through “Adalite” (decided to send me coins to “Yoroi” and stake it there). Everything was very smooth and easy. Thanks for replays.