CNTools and gLiveView error failed to load common env file

my bp and relaye worked just fine but suddenly bp connection droped and after that every time i try to run ./gLiveView.sh or ./cntools.sh same error happens bu relay still looks just fine and working tried to compare two nodes but no , every thing looks just fine

sudo systemctl status cnode

hi alex i did it but no nothing
Capture

Check the topology file… this can happens if the nodes doesn’t have OUT connectivity with other nodes

yes i checked it according to your guide i set everything up and checke it serveral times after the issue and before that there were no problem .
in topology.json in bp only added ip and port for my relay

add this for test in your topology file and restart the node, it’s syncing now?

{
  "addr": "relays-new.cardano-mainnet.iohk.io",
  "port": 3001,
  "valency": 2
}

no still the same error

did u modified the env file?
how is the socket line… commented or uncommented?

no just cnod
photo_2021-05-04_17-25-03

try to uncomment the socket line and restart the node

still same error
Capture

Not ok, u are using cntools right?
Try to delete scripts folder and download the scripts again

cd $CNODE_HOME

ls -l
Sudo rm -R scripts

cd ~/tmp
./prereqs.sh

Then go and edit again the env file and restart the node

Cheers,

DONE this but no changes still nothing

type journalctl -e -f -u cnode.service

As u can see it was an issue with the topology file… now

Go in env and tell me , the socket is commeted or uncommented?

U can delete the above picture… the user is shown

its commeted then i uncommented it and restart cnod and sadly nothing
i wonder why is running prereqs.sh again doesn’t solve it and i shoud say after re runing prereqs.sh everything turned to default except cnode that was uncommented and on port 6000

U can try but after u restart the node try

sudo systemctl status cnode

still no changes

One stupid question, how long do you let it on?

For instance, once you get this error let the BP on without doing anything for at least 10mins. Then run ./gLiveView.sh

Do you still get the same error?

[crypto_1982] :thank you for your attention . yes tried to onboth nodes. bp tried to shout down , restart , leave it behind , let the relay work , shout down relay restart relay , shout down both restart both . but relay working like a charm and stable but on the other hands bp failed.