Connecting Ledger nano X to daedalus

I always have trouble connecting my ledger nano X to daedalus… My ledger is up to date, everytime I try to recieve a transaction I select a recieving address, daedalus asks me to connect my ledger and enter pin, then nothing happens. Occassionally it asks me to open the Cardano app but then asks me to unlock my ledger… and then nothing happens. Starting with the cardano app already open has occassionally worked but not regularly, every time I click on the cardano app the “disconnect” sound plays on my pc however the ledger displays the connected and drawing power icon in the top right corner. I have somehow managed to make it connect the last 4 times but after multiple tries and it is extremely frustrating. Any help would be appreciated.

If u have issues with daedalus u have alternatives:

Cheers,

Hi @Theredonion,

I would try the following:

  1. connect your ledger to adalite.io and see if this works fine.
    If this has the same problems then try connecting your ledger to another USB drive. Also double check you have the newest ledger firmwares installed
    If this works then go to next point. These instructions I have received from IOHK support before. Read through it before actually performing it!

Recovery Check

  1. Open the state directory

  2. Delete wallets folder.

  3. Pair your hardware wallet on Daedalus


  4. Your wallet starts the sync from 0% and please wait to complete it. ​

When I use a USB hub (like the one on my monitor) it is more unstable. The best connection (in my opinion) is connecting the USB cable directly to the computer. And also a good USB cable. The original cable gives me the most stable connection: Ledger OTG Kit | Ledger

Thanks everyone for the replies and advice. I only use the origional ledger cable (my nano x is oly 2 months old), I dont use a USB hub, the firmware is up to date and I seem to have no trouble with Yoroi or adalite.io… Guess I will stick with these instead for now and if I have any further issues I will try the recovery if anything else fails.
Thanks again.

[Edit - mine was a stupid user problem, use Ledger’s own cable and it worked fine.]

Looks like another having the same issue. New Nano X. Updated firmware. Daedalus 4.2.1#18759.

I’m trying to do a redelegation, and Daedalus says connect Ledger and enter pin. Doing that, nothing happens.

I’ve tried restarting Daedalus and various combinations of the transaction with the Nano open on the ADA app, Nano disconnected and then connect, main ledger screen.

It appears that Daedalus simply does not see the Ledger and nothing I’ve tried works.

Same machine and Nano, I was able to create the wallet and delegate on 2 weeks ago, but now it is not responding.

Any more ideas?

I can’t remember exactly the order but, try to :

  • start daedelus first and then connect ledger
  • connect first ledger and then try to open daedalus

OK, first its embarrassing to admit that the core problem was a ''stupid user problem", but to help someone else avoid the headache here’s what I found.

I was using another USB-C cable and once I switched it back to Ledger’s own cable, all worked fine. So that cable likely is power only, not data.

2 Likes

I had very similar issues but in my case it wasn’t a bad USB cable.

Following these instructions, to set the right udev rules for the Ledger device in Ubuntu solved my issues with Ledger Live, Daedalus and Adalite.