Ever Since Dadaelus 4.5.0 I ahv enot been able to Pair my Nano X ledger

As per subject, “Ever Since Dadaelus 4.5.0 I have not been able to Pair my Nano X ledger” I launched it fine on Yoroi and can see my ADA holdings and Staking. In Fact Yoroi Shows MUCH more pertinent Data on the staking and various things making Yoroi MUCH desireable.

All that said Dadaelus is being a total PITA. It just refuses to see my Nano X when I pair All I get is the screen Saying “Connect your device and Enter your Pin”

The Nano X

  1. I have tried in Multiple USB ports
  2. Tried various combinations of connecting the device as in Having it opened into Cardano App on the ledger or Opening it up only after clicking the pair button

And All I get is this screen and on the Ledger

“Waiting for commands”

This has been very frustrating for the last week and I’d love for this to get more notice since I have seen more and more Ledger Nano X connection problems with Dadaelus


try to connect first the ledger then open daedalus… or viceversa (I can’t remember well right now)

If I open Nano X first, then open Daedalus, then when prompted to open the Cardanno app on Nano X, I get the message “Connect your Device and enter your PIN to unlock it”

If I open Daedalus first, click pair, then connect Nano X, Then open the Cardano app on Nano X then connect The Nano X I get the same message “Connect your Device and enter your PIN to unlock it”

This is entirely frustrating. Thankfully there is Yoroi, which I tested by sending 2 ADA via Yoroi and the ledger attached to another holding address and it works fine. I just honestly do not understand how Daedalus cannot work as simply But thanks for your response

1 Like

Also adalite.io and I’m sure there are more and possible in the festure to be added on ledger live (ADA)

What browser are you using? I found that Yoroi + Ledger on Firefox just doesn’t work. Chrome did.

Chrome worked for me