Couldnt Pack log file, pub/node.pub doesnt exist/ connecting to network. 2 weeks and no response from support


#1

Hello, i made a post earlier this week that i uninstalled and reinstalled the wallet 3 times. The 4th time i uninstalled, i deleted all Daedalus files in %appdata%. This caused the 4th installation to start syncing the blockchain from 0%. It completed at 100% no problem the first time it launched, but I could not restore my wallet as it was an ever ending circular loop for 16 hours until i just quit the wallet restoration process. Now everytime i launch daedalus, i get “connecting to network” and “could not pack log files” Here are 2 pictures of the errors.


#2

Same with me. Both problems.
Even though I run it as admin.


#3

@RobMcvay and @rfaraco I used to use Windows in the past and still do for work, but not at home. I would have problems with Windows programs sometimes after my operating system was used and abused for a while and a lot of programs installed, upgraded, deleted, repeat. Even my Mac needs a tidy up once in while.

Here are a set suggestions that I would do for Windows that may help (of course you may have already tried):

  1. First - delete all old unnecessary programs.
  2. Then - remove programs from automatic startup that run in the background. I am amazed at how many sneak through.
  3. Run ccleaner FREE version. https://www.ccleaner.com/ccleaner/download
  4. Reboot after steps 1-3. I think ccleaner will prompt you to reboot.
  5. Update all OS Patches.
  6. reboot.
  7. Run a full system virus scan with the latest virus scanner updates.
  8. Run malware bytes also if the virus scanner will let you https://www.malwarebytes.com
  9. After all cleaning and updating is complete, run defrag or some disk defragmenter unless you have an SSD.

Then try installing Daedalus. Make sure any unnecessary programs are not running during the install.

Good luck,
Rick


#4

Same problem. All steps did not fix it


#5

Ok. Thanks. Worst wallet - cardano


#6

I managed to reproduce your error on Windows 10 (Version 1709, OS Build 16299.15 and 16299.309):

  • Error pop-up with the message Couldn’t pack log files, reason: can’t pack log file pub\node.pub because it doesn’t exist or it’s not a file
  • After clicking OK on the error pop-up, the Daedalus GUI appears and is stuck on Connecting to network…

by doing this:

  1. Install Daedalus using daedalus-win64-1.1.4883.0-installer.exe.
  2. Start Daedalus via the desktop shortcut. At this point it works as intended, no error message, starts synchronizing.
  3. Exit Daedalus.
  4. Delete the %appdata%\Daedalus directory.
  5. Start Daedalus again via the desktop shortcut.

I’m not certain that this caused the issue on your end, but it would be worth a shot to reset Daedalus completely, if you didn’t try it already:

  1. Make sure you have your 12 recovery words.
  2. Exit and uninstall Daedalus. You can reboot also, to make sure that Daedalus isn’t running in the background anymore, which was an issue with older versions.
  3. Remove or rename %appdata%\Daedalus on Windows, or ~/Library/Application Support/Daedalus/ on macOS. This directory is about 5GB in size and might take a while to remove, because it contains about a million small files. Renaming is instant and that way you have a backup copy.
  4. Install the most recent version of Daedalus: https://daedaluswallet.io/#download
  5. Start Daedalus, wait to sync, then restore your wallet. Don’t interrupt the syncing or restoration processes, they both take hours.

I understand that you tried reinstalling Deadalus, but it’s important to reinstall after deleting %appdata%\Daedalus.


Wallet Update Error
#7

the thing is, the desktop shortcut does not launch the wallet for me…i have to “open file location” and look for the actual Daedalus application, then it starts…


#8

Please check my reply to you in the other thread, leftover shortcuts don’t work with latest version.


#9

Good point. This is what I see on Windows with a working Daedalus v1.1.4883 installation, when I right-click the desktop shortcut of Daedalus and select Properties:

  • Target: "C:\Program Files\Daedalus\cardano-launcher.exe"
  • Start in: "C:\Program Files\Daedalus"

If you have the most recent version of Daedalus installed, then it should say cardano-launcher.exe at the end of Target. It shouldn’t end in daedalus.bat, that was used in older versions.

@RobMcvay That’s very helpful information. When I follow the steps you described, Daedalus says Connecting to network… and will indeed get stuck there:

  1. Right-click on the Daedalus desktop shortcut
  2. Choose Open file location
  3. Double-click Daedalus.exe

We’re not supposed to launch Daedalus.exe directly. Try starting cardano-launcher.exe instead. I have tried and it worked in my case:

  1. Double-click cardano-launcher.exe

If Daedalus starts up normally, then you can fix the shortcut on your desktop like I described above.


#10

I just uninstalled Daedalus with CCleaner (Never uninstalled it like that before) and am currently in the process of deleting the entire Daedalus folder under “%appdata%” I am aware this will take hours, but hopefully the deletion process will be complete when i get home from work.
Also, When I uninstalled daedalus with CCleaner, it said that certain files could not be removed, and that i have to delete the “registry value”…How do i do this? It seems like i have to do this manually since CCleaner wasnt able to.
NOTE: when i tried to launch the wallet with “cardano launcher” all i would get is “connecting to network”…