Daedalus (1.0.3619) connecting to network... for a good 3-5 hours. Please help

Hello all,

I bought Cardano back in late 2017-early 2018 time period. I saw the potential of this coin back then and the only way to store that coin that I knew of was in the Daedalus wallet. Today, after 3-4 years I am opening that Daedalus wallet (version 1.0.3619) on my macbook application (mac os version macos catalina 10.15.7) and it has been showing connecting to network… for a good 3-5 hours. I believe I had Cardano coins in this and now I am scared I may not even be able to access them. It is still connecting to network…Any help will be appreciated. I humbly request if you all could assist me with this situation and what I can do to resolve this issue.

Kind Regards,

Do you keep your recovery words?
May try to recover it in Yoroi (mobile app) to see that everything is there.

Hi Rosmit,

Thanks for your response. Unfortunately, I pulled out a drawer of all the recovery words i kept for different wallets and 1 specific ledger nano and I found none for the Daedalus wallet. I don’t have any memory of creating a recovery phrase or getting a recovery phrase when I first opened a Daedalus wallet to be honest. From what I recollect, all I needed to do at that time was open my Daedalus wallet and it will show connecting to network and in 10-15 seconds, I would see my Cardano coins in the wallet. It never occurred to me that one day, this very convenience offered to me would cease to exist! I am basically browsing other topics where people have this issue but to no avail. I deleted my open.lock in the log file and reopened the Daedalus application but it is still connecting to network…

Hi @aksharp99 ,

Have you downloaded the latest Daedalus software? Please follow the link here if you have not:

It may be worth considering a clean uninstall as well, as outlined here:

With a new, clean install, please wait for Daedalus to sync to the blockchain, this WILL take a while. After that you can restore your old wallet. If it’s from back in the day, you will have to restore a Byron Era wallet. If you had associated a hardware key to it (your Ledger), you will have to use that.

Let us know how you go, we’ll try step after step to help you recover your old wallet.

All the best,


Hi @Adrem,

Thanks for your response. I will try your suggested methods and perform a clean uninstall as well as a clean new install. I will keep you updated on my progress and hopefully, I will be able to recover my old wallet.

Thanks much!

Update: I’ve currently completed a clean uninstall of Daedalus and removed wallet’s data. I’ll now go ahead and do a new, clean install.

@Adrem Just completed a clean new install of Daedalus. What should i do now?

Sorry for the late reply,

I’m only on mobile. If you have an old daedalus wallet you should go for restore.

Let us know how you go.



Hi Adrem,

I have the same issue with the old Daedalus Wallet (1.0.3619) which does not find a connection to the network.

I have followed the recommended steps as follows:

  • Installed new Daedalus Wallet (Mainnet) on another computer.
  • Tried to restore the wallet with the 12 words code.
  • It shows 0 ADA, which is not the right balance.

I am urgently looking for a solution to reconnect the Daedalus wallet (1.0.3619) to the network, because the the recovery process on the Daedalus Wallet (Mainnet) seams not to work.

Thank you in advance for further support.

@Thorvanthor ,

I am sorry to hear about your issue. I’ll try my best to help.

  • Make sure your Daedalus wallet software is the latest version (3.3.0#16556);

  • Let Daedalus sync to the blockchain in full before attempting recovery (this will take a while)

  • Your old wallet is a Byron Legacy Wallet (12 words), so please ensure you select the right option, as follows:

Once Daedalus is fully synced, click “Add wallet”. In the dialogue that follows , choose “Restore”. Select “Daedalus wallet” and then “12 words (Byron legacy wallet)”.

If the above doesn’t work and the funds do not show the correct balance even once Daedalus is fully synced, please check the options provided in “Import wallets”. This is geared toward old wallets (0.15.1 and previous) in case you still have access to the “secret.key” file or the old Daedalus state directory.

I hope this helps, let me know how it goes.



Hi Adrem

Thanks for the support so fare.

With the new version (3.3.0#16556) and the added feature i could restore a part of my ADAs fund.

The wallet shows all of the transactions by the end of the 2017.

Steps i did:
-Installed the newest version (3.3.0#16556).

  • Trough the “Import wallets” feature, i inserted the “secret.key” file.
  • Transaction by the year 2017 - history and amount of ADA are displayed.

Unfortunately the transaction in 2018 are still not restored. Do you have any further advices how to get along with this issue?

Thank you in advanced.


1 Like

@Thorvanthor ,

Apologies for the late reply. I am glad to hear you managed to restore your wallet and are able to see (at least part of) your old transactions.

If i understand correctly, you can see all the txns up until 2017 and not subsequent years. Let’s try to troubleshoot this:

  1. Has Daedalus had the time to fully sync to the chain?
  2. Did it give you the warning about updating to 3.3.1?
  3. Were all the txns performed to/from the same wallet?
  4. If not, is it possible that you might have another wallet?

Let me know what you find. If all else fail it may be worth having a look at your onchain data with things like https://explorer.cardano.org/en.

Let me know how you go and all the best,