Daedalus 2.1.0 (#14079) Node Crashing Constantly

I’m on a MacBook Pro 13" (Catalina 10.15.6) using the latest Daedalus 2.1.0.

Can’t even get it to load. It shows “Network Connection lost- reconnecting” for some period of seconds to minutes then “Loading wallet” for a few seconds then “Node Crash”. Then repeats this sequence over and over for 30+ minutes until I run out of battery since it is a resource hog.

Tried reinstalling. Tried rebooting. Tried turning off my computer and back on again. I’m on Fiber, so it isn’t my internet connection.

Anybody know how to fix this? If unfixable, I’m just not sure the Daedalus team is doing their QA before release. The last version 2.0.1 kept slowing down or freezing nearing the 99% validation and also on the blockchain download, runs my battery down 10% every 10 minutes and now they upgrade to 2.1.0 and it is now worse?

Thanks in advance.

I’m using Centos 8, and I almost open and sync everyday, I never found this matter.

This sounds like a resources issue. How much RAM do you have? 8Gig would be a minimum.

runs my battery down 10% every 10 minutes

While it is syncing it is validating the block chain. That is a CPU intensive operation.

Daedalus is a wallet that includes a full node. There are lighter weight wallets like Yoroi, but do your own research.

I have 16gig of RAM, so I don’t think that is the issue.

I’ve sent logs and the response from the team is that this is expected for it to be intensive and battery draining until it is optimized. I get that they have more work to do for optimization, but this type of resource hogging has been reported for several months now even on previous versions. It was reported by even in Daedalus’ notes that it was going to be addressed in future versions but several versions have come out since then and it still occurs.

I finally solved the Node crashing by deleting the state and re-downloading the entire blockchain (recommended by support), which even on a gigabit symmetric internet connection and a Macbook Pro, took approximately 7 hours. I’ve had to do this a few times in the past to solve similar problems, but it is really unreasonable to have users do this rather than the team solving the underlying problem leading to it.

I see the potential, but I feel the Daedalus team needs to work these bugs out in a more timely fashion.


I moved my Daedalus from a Windows 10 PC to MAC. Windows 10 it was chewing up CPU all day. But now on the MAC is crashes all the time. Are you still having issues with Daedalus crashing on the MAC?

No, after deleting the program and the blockchain with it, then RE downloading Daedalus and the blockchain like described above, I’ve had no further issue on my Mac. Just make sure to delete everything first then download the latest version directly from the official site.

I’ve noticed it is still a bit resource intensive, but less so than it was a few months ago. Hopefully they continue to optimize this further.

It’s working great now and I’m delighted to see hardware support in the newest version!

I appreciate your reply. I will delete it all and try it again. Thank you!