Daedalus 4.3.1 not working since Alonzo

Opened Daedalus today, “The delegation center is not available because you currently do not have and shelley-compatable wallets.”
I went to “restore” and added my 24 word seed phrase, and new wallet name and password, but got an error message, and could not successfully restore wallet. No further explanation, just “error”. Trying not to stress out. Pls help. Thanks

Are you meeting the minimum system requirements ? If not, you will run into so odd issues.

Im on a new Mac, Daedalus has been working fine for many months until today.

Whether your Mac is new or old is irrelevant. What is relevant is whether it has enough RAM or not.

The blockchain and more importantly the UTxO set is growing, so that means the RAM requirements are growing.

I have 64GB 2667 MHz DDR4 with 796 GB free on a 2 TB HD. Again, Daedalus was working fine until today.

Ok, you have more than enough RAM. What version of Daedalus are you running?

version 4.3.1

I just opened it again and now its working fine. I have no idea what changed or why I got the error message or how it went back to normal, but its working and there is some glitch, but its working again.

Glad to hear! No idea what was wrong though.

I have the same issue. when i used my 24 word past phrase, it show error. When I closed Daedalus and open it back up, it worked fine. Well, today, I am running into the same error message again. Have tried restarting a few times and nothing. I am considering uninstalling Daedalus all together and installing a new copy, just worry about the long wait time to download the entire blockchain over again.