Daedalus NTP Service Unreachable

Opened Daedalus today and was greeted with red screen saying Daedalus unable to check if the clock on computer is synchronized. I’m using Norton, but I have Daedalus configured as allowed under the programs and firewall settings. Double checked Windows time and date settings and sync’d for good measure. Also went to Daedalus → Help → Daedalus Diagnostics → check time. However it says NTP service unreachable.

Updated to Daedalus 4.4.0 today, build number 19288, but still the same issue. Red screen cannot synchronize with clock.

Any resolution?

Hello @cardj4

There is a post from a few months ago on how to resolve Network Time out of sync. Maybe try this and see if it works with 4.4.0 version: https://iohk.zendesk.com/hc/en-us/articles/360010230873-Machine-clock-out-of-sync-with-Cardano-network

Thanks for this. Unfortunately this was the remedy that I was talking about that I had tried but did not work.

Daedalus check time does nothing at the moment.

Did you try to manually fix Windows time as per that link above, just manual method (below the first fix). Also, you can try disabling Norton while doing this, see if it makes any difference. .

Also, did you change permissions for primary DNS before this issue started or did anything to change which DNS is used? Any new permissions for router/network/ ISP provider If so, try to revert back and check. .

Yes I’ve already tried what’s on the link. My time was not off to begin with. Even after syncing it anyway nothing helped.

Disabled Norton and tried again with no change. Still red screen with NTP service unreachable.

I have not made any changes before this issue started. My ISP is also a static ip.

So, your Daedalus screen is saying System time correct: NO .

You can try to restart the service. Try this:

  1. Hold WinKey +R
  2. Type: services.msc , then click OK
  3. Scroll down to "Windows Time’ and right click
  4. Select Properties
  5. In Startup Type select Manual (If it’s not selected already)
  6. Then click ‘Start’ below services status.
    Now go back to Daedalus.
    If it’s not doing anything click check time. (may need to click a bunch of times, depends on our system/ internet lag)

This is assuming that you already checked (and turned off) your Norton and Windows firewall and restarted the modem /router solutions already.

Still not working. Tried it. Thanks for the recommendation.

Still the same situation today. Network and time settings seems fine.
Should I just Continue without clock synchronization checks?

You already synced the time in previous step. Maybe if you continue it will update it.
I would try and see if it resolves.

Actually the Daedalus has not Sync’d with the time yet. It continues to fail to do so. I was told continuing without clock is ok for now. But doing that the wallet continues without sync and recognizes the time, but doesn’t view it as synced properly. Support suggested I just leave Daedalus running until it syncs. Still waiting for it to do so. Already updated to 4.4.1.


There is an easy fix for this in WIN 10… just go to Settings then time And Language Look for the "Synchronize your clock’s “Sync Now” Button. Click it…

Go back to Daedalus into diagnostics and have it check the time again… this usually takes care of the issue

Hello. Thank you for the reply. This was the first think I tried. I still have the same error today. However, support says it’s fine to continue without clock sync for now.

Wondering if I should do a fresh install of Daedalus. Any idea what to back up?

Just an update. I’ve now tried rebuilding the Daedalus state directory and recovering the wallets. Still the same result with the red page.

Double checked firewall settings again with the same result.


I think the only time it actually detected the NTP service was when it was booting up Daedalus. But after it gets in I get NTP service unreachable.


I may have found the solution. Go to router and manually set the DNS servers to google servers. Strange that the old settings would have been blocked.

Google DNS seems to work.


I had this same issue but was only using the default Windows Defender firewall on Windows 10. What fixed it was going to the firewall settings, clicking Allow an App through the firewall, and making sure both Daedalus and Cardano Node were allowed through. For some reason they showed up twice in the list and had different defaults.