Daedalus stuck at Syncing Block 100%


#1

Hi.
I have just updated Daedalus today, then I opened new version of Daedalus, but I got stuck at “Syncing blocks 100%”.
Please help.

Thanks


#2

Sorry you’re having this trouble. I just copied this answer from the FAQ:

Please note that blocks are synced in steps, each of which might take up to a minute. If Daedalus is stuck at X.XX% value for several minutes, please check your internet connection and try to restart Daedalus. If the internet connection is stable and syncing is still freezing after the restart, please follow the instruction below to reset the blocks in your PC.

Win:

Type %appdata% on the explorer’s address bar
Open Daedalus folder
Delete the content of DB-1.0

Mac:

On the Finder’s menu bar select Go
Click Go to Finder…
Type ~/Library/Application Support/Daedalus
Delete the content of the DB-1.0 folder


#3

Wouldn’t the 99.9% of downloaded blocks be deleted if you do that?


#4

What’s your OS? I’ve experienced this situation with Windows Server 2016 Standard (Version 1607, OS Build 14393.693). @RobJF’s recommendation did not fix the problem.

@Miner Yes, all of the previously synced blockchain data would be lost.


#5

Hmmm…ever since the update, I’ve been running 100% faster and have never dropped a connection.


#6

I have no problem with the wallet I downloaded sometime in December and upgraded to 1.1.4883

I have failed to sync the blockchain AND recover my wallet on 2 separate rigs. I am trying again on a third. If you have another system see if you can recover your wallet from your seed.

Good Luck!


#7

Hi all, I have the same issue, cannot go to wallet, it keeps syncing blocks 100% all time, I did delete content of DB-1.0 to re-sync, uninstall and reinstall, the issue still there, I have ADA in my wallet, how could I move?


#8

I can confirm the issue on Windows 10 Enterprise (Version 1709, OS Build 16299.309) also, using Daedalus Windows Build v1.1.4883 (Daedalus v0.9.0, Cardano v1.1.0). It’s a fresh Windows installation, using an ISO image from https://microsoft.com/, with no software other than Daedalus installed. It’s running in a virtualized environment.

Rebooting the computer didn’t help, nor did starting over after uninstalling Daedalus and removing %appdata%\Daedalus.

I’ve done an experiment where I started and exited Daedalus 15 times, letting it run for 5+ minutes every time, saving logs of each attempt. It worked normally on the 5th and 6th tries, but otherwise it got stuck on the initial screen with the message Syncing blocks… 100.00%. When it got stuck, it didn’t matter that I let it run for 1-2 hours, it never continued. When it worked, it continued instantly after syncing finished.

  • There are no errors, exceptions or out of the ordinary messages in any of the log files:
    • Daedalus.log
    • launcher
    • node.pub
  • Local block count catches up to network block count always, as reported by debug messages in Daedalus.log.
  • These messages are only present in Daedalus.log on successful attempts:
    • [info] ========== Synced after <n> milliseconds ==========
    • [info] ========== Loaded after <n> milliseconds ==========

@lamht What version of Windows are you running exactly? If you need to move your ADA urgently, then as a workaround you can try quitting and then starting Daedalus again, a few times. I’m not certain it’ll work in your case, but it did for me on Windows 10. Or restore your wallet to a different computer.

@Miner Do you also have the problem of getting stuck on Syncing blocks… 100.00%?


Restored my Daedalus wallet - synced 100% = balance zero
#9

@FairCopy, I see you responded me on 2 threads, thank you, I will answer here since this is exactly my issue. Yes, my Windows is Win10 Enterprise, Version 10.0.14393 Build 14393. I’ll follow your solution today and report back…


#10

I never got stuck at 100%
I was successful in downloading and recovering my wallet on 2 systems out of 3.
All were recent builds of Windows 10 pro. Seems I do that a lot :wink:


#11

Yes @Miner, you’re using Win10 Pro, seem the issue happen with Win10 Enterprise


#12

No luck with multiple opening for a while + closing for a while. I think I need to try with another PC with another Windows.


#13

I figured out the cause. The cardano-node process tries to connect to these NTP servers:

  • 0.pool.ntp.org
  • 2.pool.ntp.org
  • 3.pool.ntp.org

Daedalus only gets stuck at Syncing blocks… 100.00% if it can’t reach the NTP service on these servers. There are warning messages in the node.pub log file that I failed to notice before:

[node.ntp-check:DEBUG:ThreadId 605] [2018-03-23 14:22:15.19 UTC] Collecting responses
[node.ntp-check:WARNING:ThreadId 605] [2018-03-23 14:22:15.19 UTC] No servers responded

@lamht @ChiBui I couldn’t find an easy solution to the problem. :slightly_frowning_face: There doesn’t seem to be a way to simply disable this feature or to change NTP servers by editing config files. As a workaround, try a different Internet uplink, e.g. cellular instead of your regular cable connection, or try restarting your router.


#14

IOHK should pay you! :grinning:


#15

thanks all. I’ve tried all the suggestion but it’s still the same. Any other ideals ?


#16

I’m sorry but you need to provide more information. Saying you tried “all the suggestions” isn’t enough to let us help you. What did you try, what happened, exactly what is happening now?


#18

This is like telling your friend who offers to fix your car when he asks you what have you tried so far to solve the problem and what exactly is the problem?

Sorry but it’s the stupid car… You might not remain friends, and i’m pretty sure he can’t fix it if you provide zero feedback.

You could make a new post in the community technical support category, explain the issue, tell the nice people who offer their time to help you what you have tried so far, provide screenshots, feedback and so on.

Just a friendly suggestion if you truly are looking for help. Now it just looks like you are trolling us… :wink: