Daedalus Update and Connecting to Network Stuck


#1

Hello all,

So, I downloaded and installed Daedalus on the 25th of Feb. I was able to set up wallet and have been transferring ADA on a regular basis. I felt lucky I hadn’t had any issues. Today I was wanting to update, a Version 4 button had appeared in my daedalus. I clicked it, to no avail. A bit later an installer window showed up but I cancelled out of it. I am not sure that this is relevant to the problem I am having now.

I had never had any connection issues. But I have been trying to open my daedalus for several hours and attempts, and it is stuck at connecting to network. Pretty sure my network is fine. As I am downloading daedalus now to a 2nd computer.

Anyways Im using Mac OS high sierra. I was able to get these notes from daedalus helper.

[launcher:INFO] [2018-03-08 22:25:42 CST] using configurations: ConfigurationOptions {cfoFilePath = “./configuration.yaml”, cfoKey = “mainnet_wallet_macos64”, cfoSystemStart = Nothing}
[launcher:NOTICE] [2018-03-08 22:25:43 CST] LAUNCHER STARTED
[launcher:INFO] [2018-03-08 22:25:43 CST] Running in the client scenario
[launcher:NOTICE] [2018-03-08 22:25:43 CST] Running the updater
[launcher:WARNING] [2018-03-08 22:25:43 CST] The updater has failed (exit code 1)
[launcher:NOTICE] [2018-03-08 22:25:43 CST] Starting the node
[launcher:INFO] [2018-03-08 22:25:43 CST] Node has started
[launcher:NOTICE] [2018-03-08 22:25:43 CST] Starting the wallet
[launcher:WARNING] [2018-03-08 22:25:45 CST] The node has exited with ExitFailure 1
[launcher:INFO] [2018-03-08 22:25:45 CST] Waiting for the wallet to die

If anyone could help me out here, it would be greatly appreciated. The last note is a bit concerning to me, hope that my wallet isn’t dying. Ive deposited a fair amount of ADA in there. And now I am growing a bit concerned.

Despite this I am hopeful for the future of Cardano.


#2

Try restarting the mac. If still the problem exist try re-syncing the wallet by deleting DB folder and restart the mac

On the Finder’s menu bar select Go
Click Go to Finder…
Type ~/Library/Application Support/Daedalus
Delete the content of the DB-1.0 folder


#3

Thanks!

I disabled firewall, messed with anti-virus settings. Restarted and it loaded right up. Then I enabled firewall and Anti-virus settings. Restarted, still worked.

Thought maybe I had shut down and restarted since having the issues initially, but my memory could be failing me. :see_no_evil: Regardless we are good to go now.

The most obvious and simplest solution.

Thanks again Jam


#4

Ok, so my Daedalus has been running smoothly, no futher issues. However I am still running version 1.0.3619 and at one moment there was an update version button that had appeared in the interface, but has since dissapeared.

Do I need to uninstall my current version then download the latest version from the Daedalus site in order to update? My hesitation is that I may encounter the 100% block syncing issues I’ve seen others have. I am not currently having any issues other than I am running an outdated version.

@Jam35x had suggested trying to:

Blockquote
On the Finder’s menu bar select Go
Click Go to Finder…
Type ~/Library/Application Support/Daedalus
Delete the content of the DB-1.0 folder

However this content is not located here. I can access Daedalus files from “Show Package contents” from the daedalus applications icon. But I don’t know where to begin to start looking from there.


#5

No, you don’t have to uninstall the current version. You can download and install the newer version over it.

If your Daedalus is working fine, you don’t have to worry about it.


#6

Thanks for the clarification!