Daedalus Wallet Portability, Password and Restore Issues


#1

With the increased value of the coin, I wanted to move my ADAs to my own wallet. Usually I install the wallet app in my USB stick so that I can keep it offline. So I did the same thing with Daedalus. Installed it on a USB stick on my desktop. After installation I ran it using the exe name but that got stuck at “Connecting to Network…”. A little research showed that I was supposed to run the bat file instead, and that worked. It started up, but of course took forever to sync. It finally finished sync’ing. I was happy. But before I would do any test transaction, I thought I am going to try to plug the USB stick into my laptop and try to run it from there.

When I tried, it started up but got stuck again on “Connecting to Network…”. This time of course I was trying the bat file not the exe, but still stuck. So I thought ok looks like it is not portable and can’t be stored in the USB stick. That was a bummer, but I thought that’s fine, I will worry about it later.

I moved the stick back into my desktop, and ran the app again and it came up fine. So I created a wallet, noted the seed and created a password. I then initiated a test transaction from Binance of 4 ADAs, which after fee were supposed to be 3 ADAs.

After some time the 3 ADAs showed up in my wallet. So far not bad.

I now tried to send the coins back to Binance for a full round-trip test, before I would make the real transaction, and I am so glad I did.

When I tried that, it asked me for the password. I gave the password, but it says it is invalid. I can swear I know what password I set before. But it just doesn’t want to take it.

I wonder if this happened because of installing Daedalus on USB stick. If so, I think it is a serious bug in the wallet.

Anyways, I deleted that wallet, and created a new one wallet with the same seed. It asked me to create my new password which was good. But now it is stuck at RESTORE WALLET screen with white circle circling on the Blue button for the past two to three hours. I don’t know if it is taking too long or it is hung.

I am definitely not having a very good experience. I am glad that it is just 3 ADAs I am dealing with, but it could be my entire investment. Any idea what’s going on here?


#2

After a Restore of Wallet the application has to work through the whole blockchain again. The fact it was “stuck” is not a problem.

Here is some info from the Daedalus FAQ

  • When I restore my wallet, the application freezes: This is not a bug, it is actually trying fetch whole transaction history. The reason why it takes such a long time is because it is traversing through the whole blockchain to get the wallet synced.

I don’t think the Wallet was ever intended to be a USB Portable APP at this point. You can install on more than one computer if needed.