Does Daedalus Wallet on Mac Require "Full Disk Access"?


#1

This pertains to Macs running 10.14.0 and above. Are there any docs or official recommendations to grant Dadaelus Wallet “Full Disk Access” in System Preferences -> Security & Privacy? I don’t recall seeing any.

The reason I ask is because I just did the upgrade for Daedalus and it then did a wallet restore. I was stuck at 10% complete for about 20 hours. I quit Daedalus, rebooted my Mac, and then granted Daedalus “Full Disk Access” and now it’s moving right along.


#2

When you grant “Full Disk Access” to an app it is added to the white-list of applications that are now marked as safe to work with… your Mail, Messages, Safari, Home, Time Machine.

The Mac equivalent of %APPDATA% is under Home, so that makes sense.


#3

The entire restore was completed in about an hour after granting “Full Disk Access”.


#4

Hi Duane,
I have zero programs in the “Allow Full Disk Access” and my Daedalus upgrade installed. I am running 10.14.2 Mojave and my normal user account does not have administrator rights. I did have a Cadano Node Crashed one MacBook, but that cleared with a restart, and the other MacBook was fine.

Hope this helps.

Cheers,
Rick


#5

Hi Rick,

Per the developers instructions I have had to grant 2 apps full disk access. Those are ChronoSync and SpamSieve. I also added Terminal because I added commands to my environment. I also added MAMP Pro.

What I’m learning from developers is that it’s also that helper apps that come with an app, perhaps embedded, that may be running afoul of the full disk access issue. Particularly in the ~/Library directory and that is where the Daedalus data lives.

After 20 hours of waiting I had run out of patience. I quit Daedalus and restarted it. It started up fine and appeared to pick up on the wallet restore process. But the apps I needed to work with were still in what I call a “zombie” state. They were listed as “unresponsive” when I right-clicked their icon and they were listed as running in the Force quit window. If I tried to force quit them nothing happened. If I tried to use Terminal to detect if their process was running it came up with nothing. By this time I had had enough and I restarted the machine. When it came back up I added Daedalus the the full disk access list and away it went. Done restoring the wallet in a little over 1 hour. I suppose I missed an opportunity to see if the quit of Daedalus and/or the rebooting of the machine would have solved the problem prior to me granting full disk access privileges. I’ll never know at this point.


#6

Duane,
I have to use the Full Disk Access feature now, as of today. Now that I updated my AV scanner to the Mojave supported version, the AV scanner stopped at 16%. I added the app to Full Disk Access and now it will scan correctly.

It was a good thing I remembered your post, you helped me solve my AV issue. Although my Daedalus still works without it. I think more will have to be learned about the effects of this new Mac OSX Mojave security feature.

Thanks,
Rick


#7

Hi Rick,

Glad it worked out. The Full Disk Access feature is new. It just came out with Mojave in October. It makes sense that your AV would need it as it scans your entire hard drive.

I do a daily backup of my system. It usually takes less than 30 minutes to complete. When I ran the daily backup following the Daedalus upgrade it took 4 hours. It took it 3 hours just to figure out the files that had changed or been deleted. Then it backed up almost 500,000 changed Daedalus files. They were all similar to:

Users/username/Library/Application Support/Daedalus/DB-1.0/blocks/data/xx/d666121056ae9f94885589413611447b656a3e6d5e8e14bbaad2c1fc2ad068.undo

Where “username” is your user name and “xx” is a subdirectory.


#8

I’d recommend excluding global available data (like blockchain) from personal backups. Everything in DB-1.0.


#9

Ah thanks. The daily backup is just a “diff” of what has been changed since the previous day so it shouldn’t take 4 hours per day for the following days, maybe?


#10

No, it was just that one time following the Daedalus rebuild. It’s been back to normal now. Less than 30 minutes.

I do a bootable backup using ChronoSync. If I have a failure all I have to do is boot off the backup. I’m a developer, I can’t afford any downtime.