Error Installing wallet

Hello Everyone,

I’m having problems trying to install the 1.1.0 wallet. I get the attached error. I’ve tried installing on multiple machines. Thanks for any ideas.Wallet Error

  1. Make sure Daedalus isnt already running
  2. If it isnt and you still get the error, Go to Task Manager > Processes (or Details) tab -> sort by name and check if cardano-node.exe is still running.
  3. If yes, kill the process and hit retry.
  4. If you still hit the error, you may need to right click installer and run it as administrator.

Notes:
The wallet has never been installed on this computer before.

I’ve tried running the installer as an admin, it seems to get farther in in the process but it doesn’t create any short cuts to the application on the desktop or in applications.

In the error is says error opening file for writing and gives a path. That path isn’t there so that error technically makes sense so the install step that puts that file there doesn’t seem to be happening.

Thanks for the help.

OK so it was point 4 (permissions). A bit confused on your current state.
Did you finish the installation successfully and still dont see the folder “C:\Program Files\Daedalus Mainnet” ?

When I right clicked and ran the installer as admin, it seemed to install files and folders but did not put a shortcut on the desktop and it didn’t add anything to applications.

Then when I try to launch the application from the icon in Program Files folder it tells me to use the icon that’s on the desktop or in Applications, which isn’t there.

Need a little more information @OxenHouse, which Microsoft OS version are you running on your system Thx not an after thought in the least but Welcome to the community

The file to run is “C:\Program Files\Daedalus Mainnet\cardano-launcher.exe” on Windows. You can manually create a shortcut to it if you want to but that shouldn’t be necessary from a technical point of view.

@Trigger Windows version 10.0.18363 Build 18363

Win ver

@RobJF I can create a desktop shortcut from the .exe location but when I try to launch from the shortcut i get the below error.

wallet error 2

This post was flagged by the community and is temporarily hidden.

I think youre still launching shortcut for Daedalus.exe, @RobJF suggested use of cardano-launcher.exe

1 Like

Using cardano-launcher.exe worked.

But the it still doesn’t solve the install problem.

If you mean the missing shortcuts, you can submit a support request, or create them manually, or both.

Well really, it’s that the installer didn’t work at all.

It should have prompted for admin creds during install instead of erroring out.

When I ran the installer as admin it should have created shortcuts. I tried to create on out of “Daedalus mainnet” which looks like the only thing with an official icon of the application but launching that errors out. When I create a shortcut out of cardano-launcher.exe it seems to work but I have a crappy looking icon representing the application. Cardano Icon

I’ll create a support request as a heads up to the team.

1 Like

You can change the icon using the shortcut properties. Select the Daedalus Mainnet.exe file as icon source. Of course this shouldn’t be necessary, which is why the support request is a good idea, if only as a heads-up, as you say.