First time Daedalus install and wallet has balance and password? Help!

Hello. I’ve been in crypto since 2014 and I’ve never seen this before. I’m new to ADA and just downloaded the Daedalus wallet for the first time ever on my Mac. After the block chain synced, the wallet opened and to my surprise there was already 1000+ coins and it was locked with a password. I went into the options and it said password last changed 6 months ago and it showed a bunch of transactions for last week. How is this possible that I downloaded someone else’s wallet off the website? I found a YouTube video of how to check the checksum for the wallet in my terminal app and it’s different than what it shows it should be on the Daedalus web page? Good thing I didn’t send any coins to the wallet and I prob would have if there wasn’t already an existing balance that wasn’t mine. Did the Daedalus page get hacked or spoofed? I’m very confused.

1 Like

I tried finding another source to download the wallet but everyone just links to the page. I tried checking the checksum from another Mac machine and again it’s coming up with a different number than what’s shown on the webpage.

1 Like

What number?

Can you PGP verify it, like in this image?

Primary fingerprint should match this:

Let me know.

1 Like

That’s mine, give it back.

1 Like

Hello @Doubleredrolex.

Can you please explain in steps where you got it from, how you created a wallet and so on? Add pictures and/or screenshots for a more clear view.

I have never heard of your problem myself, however, there is a default/example account that people sometimes, someway, somehow (accidentally) restore in Deadalus, and then send ADA to…as a possible explanation. But it doesn’t contain 1000+ADA afaik.

Alternatively to the above problem, if you feel that you have been compromised, or don’t want to use Deadalus, you can also wait for a new wallet (Chrome extension) which is planned for release halfway next month.

The wallet is called Yoroi, and doesn’t require you to synch to the entire Cardano blockchain. It can be compared to how Metamask works. - Twitter - homepage


IOHK please check this out! Having a wallet that creates duplicate private keys is obviously scary as F**K.

1 Like

Give it back I said.

Currently being looked into by the community, my guess is it will be notified to officials PDS.

Hi @Doubleredrolex did you ever have a Daedalus wallet installed on your Mac before? Did you install the latest version of Daedalus? Are your virus scans running clean? Are you using a private internet connection or a public wifi?

The big red flag is that the

Did you happen to use this video for shamus?

This one checks the signature…


I followed the links you posted and the link is Ok. You may have a virus, or something is redirecting you to a malicious web site. I did a new download and ran shasum and got the correct results…

matches this…


Rodger that! Thanks everyone!

1 Like

Sorry I don’t understand how to do that PGP thing. I just filled the instructions on the Daedalus page on how to verify checksumfor the Mac.

As for steps… I installed the Daedalus software from their page. I’ve never had a Daedalus wallet before. and When it was done there was a wallet there. I did not create a wallet. It was already there, already passworded and had a balance of about 1000 ada coins.

Virus scans are clean using two diff scanners and it’s private internet connection. I’ll just wait for an updated version of the wallet and try again.

I’m talking to Daedalus tech support on this so I will update when I get an answer.

Thanks everyone.


Does anyone else use your computer that could have installed Daedalus previously without your knowledge?

Strange…looking forward.

Looks like we just burned 1000+ ADA. That ADA is found but lost forever if you don’t have the seed phrase… strange really and scary at the same time.

Nothing strange or scarry from the software perspective. The ONLY way for newly installed Daedalus to show an existing and passworded wallet is for the Daedalus data folder to be already present on this machine. This means that some time before there were already a Daedalus installed on this exact computer, someone used it to restore their wallet with a spending password, and then they uninstalled the Daedalus itself, but the data directory remains.

That’s it. Only possible reason, obvious to anyone who have seen the code.

@Doubleredrolex, to solve this issue, please, close Daedalus, delete directory ~/Library/Application\ Support/Daedalus, and then start Daedalus again, resync, and use it fresh and new.