Forgot both my spending password and recovery phrase

Hello,

When u created the wallet, yoroi asked for a wallet name and a spending password (it was not generated automatically, u typed the pass from the keyboard).

Cheers,

How do I access the 24 word key, I have access to my Yoroi wallet on my phone for now but I don’t think I wrote it down and want to.

If you have access to your wallet, and your spending password, but not your 24 word backup phrase, you can create a new wallet with a new backup phrase (save it safely offline) and than transfer your ada from the old wallet to the new one that has a backup phrase saved. (send a small amount first to be sure you get it right)

Same problem here. I can see my wallet from Chrome but I cannot find the password or the 15 words to restore it. It would be great if the wallet could be reset in these cases.

Nope, it can’t

Do u have a ledger or trezor wallet?

If not u will need the seedword in order to restore the wallet in case u don’t remember the spending password

If u can’t find it then the only way is to try as many passwords u remember; perhaps u will find it

I have a ledger nano x - I can’t find my 15 word recovery phrase, and I don’t remember having put down a spending password.

Ok, u don’t need

Open adalite.io - hw- connect via webUSB and check for the funds

Also u can use yoroi

add wallet (shelley era) - connect ledger

I can see the funds in Yoroi (I’ve actually tried to delegate these funds about 20 times, fyi).

I’ve been talking to the Ledger help desk & the person that I am dealing with says:

a person@ Ledger (Ledger Support)

May 24, 2021, 9:26 GMT+2

Hello James,

I hope you had a good weekend and thank you for your email!

Indeed, if you lost your recovery phrase or someone has got access to it, then your funds are either just lost or compromised and might be stolen.
Yes, with Ledger you can manage only the ADA accounts related to your recovery phrase of Ledger.

Unfortunately, we can’t recover the account, we simply can’t, it is mathematically impossible since Cardano blockchain or any other blockchain is decentralized and there is no entity that can have control over the network. I suggest you contact Yoroi support and see if anything can be done in your situation.

I am sorry for your misfortune and I wish you good luck in resolving it or finding your recovery phrase.

Have a wonderful day!

All the best,

But… the funds are on ledger or in a simple yoroi wallet… if u are going on adalite.io and connect ledger… do u see the funds on ledger?
If not then u must search for the yoroi 15 seedwords or tey to remember the spending password, otherwise u will can’t move the funds… anyway do not delete the wallet from yoroi

This proposition is mathematically inexact, it’s always possible to try every combination (brute force) but it takes many years. Unless you could get your hands on one of those quantum computers to be invented. I do not know the exact key size for Cardano but let’s take a 256-bit key as an example. You would have around 2^256 possibilities (minus a few that are deemed unsafe for ECC), which makes around 115792089237316195423570985008687907853269984665640564039457584007913129639936 possibilities. With some luck, half of that could be enough. That’s unrealistic in a lifetime but not mathematically impossible.

On a more positive note, provided you remember at least parts or the size of your password, you could generate a wordlist using some tool like crunch and then use it as input for John the Ripper or Hashcat. Provided the script bitcoin2john.py would be ported to Cardano of course, here is the procedure for bitcoin wallet.

Thank you - I do remember one word (I think). Curious why Yoroi doesn’t process my staking delegations at all (created another wallet)& it also ‘greys out’ my spending password on the wallet that has the ‘problem’. There are variables like this that are curiosities that I’ll pursue - as well as the spending password that is up to 10 characters & seems like a possibility to discover (need to figure out Yoroi’s capabilities - seems like I could have some sort of program to run since there isnt a limit to password trys. I have looked at recovery password people. C’ la vie :expressionless:. Thank you for your input.

Can u share a a picture with yoroi? Of course cover the balance; it’s not clear what wallet do u have

You’re welcome, it all depends on the size of your passphrase then.

On that I’ve got no idea, I only used Yoroi to generate paper wallets so far.

Yoroi is open-source software, see Emurgo github repository. And about the program to run, it’s the idea. Even if there was a GUI limitation, you could still work on the data. The first step is reducing as much as possible the set of probable passwords, so that you (or rather a program) may try every one of them until you get a match. More generally, ECC is a compromise between ease of use and strength, but unless considering Vernam cipher, no encryption is theoretically unbreakable.

I guess they would have to develop such tools first in order to extract the encrypted or hashed key. That will probably be very expensive. In my opinion you would be better off asking Yoroi devs first about it. Wish you luck.

First thanks!

Hi there’s (3) images with notations about them below:

‘My ledger wallet’ is the place where my ADA is and where the problem is.

image_6487327.JPG

Inside ‘my Ledger wallet’ @ settings is greyed-out ‘spending password’. Not sure I ever had one:

image_123986672.JPG

Lastly here’s with the wallet where I’ve tried to delegate about 20 times:

image_6487327.JPG

Thanks for being interested - it is interesting- all happened b/c I was so freaked-out while doing this whole thing.

Thanks!

Thanks, and now… u have 2 wallets

i don’t know if I understood well, you are saying that for the ledger wallet u don’t have a spending password? You don’t have to because u will confirm the transactions from ledger devive… open cardano app on ledger and u will see a confirmation request on ledger when u will want to perform transactions… anyway connect the ledger to PC when u are doing this

How can I recover with the spending password while my trezor T can not connect anymore?

What do u mean?
Ur ADA are on trezor? If u go to adalite.io and connect HW - trezor do u see the funds?

If u have the ADA on trezor u will not need a seed words to recover the ADA

We already had chat about my issue, but suddenly I reached the maximum of chats allowed for 24h. For some reason my trezor cannot connect anymore with the yoroi wallet. Only thing I still have is a spending PW from the yoroi wallet. I tryed the adalite, but my funds are not visible there. So it looks like the connection between my trezor and my yoroi wallet is not right? Is it possible to unluck my funds with the spending PW I have from yoroi?

If the ADA were on trezor u can try to restore the trezor (using the seed words for trezor, which u received when u configured the trezor)

Also check if the cardano app + trezor bridge are up to date