Getting Blocks, but PoolTool shows Propagation Delay > 5000ms

My new pool [RAD] was lucky enough to get 3 blocks this epoch, but PoolTool is still showing “All Propagation Delays Receiver” as being more than 5000ms.

I did have some synchronization issues (related to not having chrony installed) which were fixed about 4 days ago.

Is there a significant delay with PoolTool’s metrics, or is something still off on the node?

delay

How are the nodes distributed? Same location /area?

Producer and backup producer are in Germany and New York.

Relays are in Germany, Finland, New York and San Francisco.

RTT looks reasonable as well:

out
in

I tried contacting Mike Fullman (the creator of PoolTool) at @papacarp on Telegram as well. If he gets back to me I’ll report it here.

so, do u have 4 Relays? can u show me again the glive ouput?
I think I saw only 2OUT /1IN peers on your Producer?

actually I saw u have 6 Relays? Not my business but why 6? aren’t there too many?

Yeah… there are 6 relays. I thought it might appeal to potential delegators later on to see there were more relays. That and I feel more comfortable with excessive redundancy.

Block stats are 0 as I just rebooted the node.

everything looks fine, 5000ms indeed could be to much. TBH I don’t know why that delay… hmm did u installed chrony on your servers?

and u can run cncli.sh script to check the blocks for next epochs, and the glive will be updated (BLOCKs field)

Yes, I did install chrony and it helped with a previous sync issue. I’m hoping it’s just some kind of PoolTool delay. Hopefully the propagation stats update in the next epoch.

Yes, I ran cncli for the next blocks and it reported another 3 are scheduled. Hopefully they come through as expected.

Thank you again for your help.

1 Like

you are fine, if u will go to pooltool.io/networkhealth you will see your propagation time, which is very good!

image

image

Awesome! Thank you for finding that. It sets my mind at ease.

It must just be a reporting delay on their part. :blush:

1 Like

Hi Radiant, I’m also stake pool operator and i have exactly the same issue.

I saw that your issue solved. You change something? or pooltool fix their delay?

Thank you in advance.

Yes, the PoolTool propagation reporting has updated itself without me doing anything.

If you’re seeing reported averages that seem to be inaccurate, follow Alexd1985’s advice in the above post and check your pool’s propagation speed for the last block seen.

It looks like there is a reporting delay of at least one epoch (or maybe two epochs) before the data shows up on the Metrics page for your pool.

unfortunately, i don’t minted any block yet. I believe that the correction of pool’s propagation speed is done after the block creation but i’m not sure.

Thanks