Getting this error repeatedly when setting up a node: AsyncCancelled

Hello everyone,
So I am not a stake pool operator (at least not yet), but I think this is the best place to ask my question.
I built the software and everything went fine, I can create addresses, and I started running the node without problems.
The node started synchronising with the blockchain until approximately block 150, and then I get this error (in the command line): AsyncCancelled. Just one word, and then return to command line.
If I run the graphics, everything will stop moving (CPU at a fixed percentage, memory…), and sometimes I get this: "The db is used by another process. File “/***/db" is lockedroot@vps:~/

I tried it over and over again but doesn’t seem to fix. The weird thing is that without completing node synchronisation I can’t submit Shelley transactions.

Any idea?

Hi Thomas,

Please try running:

killall cardano-node

Let me know if that frees up your resources

1 Like

Yes it’s good. I’m now at epoch 209 so it must have worked. Each time it stops I repeat the “killall” commands but it works for hours at least while syncing. Before I used this command in about 2 minutes it was stopping.

1 Like