Having a problem with my Daedalus/Trezor model T


I have a Daedalus wallet connected successfully with a Trezor model T. I have had no issues, but today was trying to send 275 Ada from the wallet. Everything was fine, up until the final screen on the Trezor, which showed 273 Ada, instead of the 275.17 and change that it should have said. So I cancelled the transaction. Then I tried to send 500 Ada, and the final screen on the Trezor T showed 273 again. So I decided to open my second new model T, and use the recovery seed from the first one to create a clone back up model T. I successfully used it with Daedalus, but again, even a 50 Ada send showed on the final screen of the model T as 273 and change. Trying not to feel panicked as most of my Ada I moved to this “safer” alternative to Daedalus alone where the seed still lives on the computer. Any help GREATLY appreciated.

Hi @DontHassleTheHosk no need for panic. As long as you dont approve the suspect transaction and you got your recovery phrase your funds are safe.

Whenever your software wallet (in this case daedalus) shows another amount then your trezor, your computer might be infected in some way. when you try to send the funds is the address shown on your trezor the correct one?

Secondly, you might want to go to adalite.io and connect your trezor wallet and try there. If this works double check if your daedalus is the genuine version. you can find it here: Daedalus - Downloads (daedaluswallet.io)

Finally try adalite on a totally fresh (other) computer. If all is fine here your other computer could be contaminated in some way. Run a malware/virusscanner to check.

What where the results? I am curious what it was.

Hey ADA4Good. Sorry, I was out with family. Thank you so much for replying, this is stressful. So first, I’m on an iMac which is connected directly with an ethernet cable on a secured network. second, this is a work computer I don’t use to surf any funny sites. Also, I ran Malwarebytes and no threats detected, and my keyboard is also directly plugged in so no bluetooth. So, I’ve been using Trezor Suite vs going to Trezor.io when I want to interact with my Trezor account. I couldn’t find my public key in Suite, so I connected my Trezor just now and went to Trezor.io, and logged in there. I found my public key and took note of the first and last 5 characters. Then logged out. When I went to my Daedalus wallet just now, and performed what I did earlier, going through the motions to send 5 Ada from my Trezor/Daedalus wallet to my Ledger/Daedalus wallet receive address, I noted that when the Trezor showed the public key, it was different from the public key I saw while on the Trezor.io website. But I don’t know if the public key showing on my Trezor was the public key of the Daedalus/Trezor wallet, which I guess might be different than the public key that would be the one that came with the Trezor? I’m thinking of recovering my wallets on my other MacBook and seeing if the same thing is happening there. Again, This is happening using 2 Trezor model T’s that are relatively new, purchased directly from Trezor, received in a locked mailbox. Thank you for helping me, this is really upsetting and out of left field, I’m so careful and I’m a veteran in this space. Not a newbie. Waiting for your reply, thank you. Also, I just restored both wallets on my other computer. There was some concern with the Trezor/Daedalus wallet seed key, as I was told by IOHK weeks ago that that wallet is restored with the Trezor seed key, which in this case is a 12 word seed key. But the option in the Daedalus wallet for 12 word seed keys, was for legacy Byron wallets. But I entered it anyway, as well as the name of the Daedalus/Trezor wallet as it has been, and it said success, and now both wallets are syncing with the block chain. My heart is racing, I’ve been so careful and I worked so hard for years to invest weekly into Cardano, this is my families future in many ways. Sorry if dramatic but this is def scary. P.S. on another security note, I can’t find anywhere in settings how to change the name that appears, like showing my first and last name-how to change that? tx

@DontHassleTheHosk I understand you are worried, but you probably don’t need to.

Let’s focus and take this step by step.

The easiest way to check if your trezor is fine is to go to adalite.io
adalite is a legit ada wallet and it’s good for our purpose since you don’t need to install anything or download the blockchain first.

Now, just click the highlighted section and in the next screen select “trezor model t”
Connect your trezor, enter your trezor pin and export your public keys.
Now you should see your trezor ada wallet and what it holds.
Now try to send a transaction and see if this works the way you expect it.

  1. Do you mean try to send a transaction while in adulate.io?

  2. I feel like something’s happening on Daedalus end maybe. So on adulate.io, the available balance and the rewards balance add up to what is in my Daedalus/trezor wallet, which is good. It is showing a rewards balance of 273.720865, which is what kept showing on my Trezor during every attempt to send Ada-this included sending 50 Ada and other amounts not in the 273 range. Like Daedalus kept spitting out my “rewards balance” (the actual number in that wallet in rewards is 314.5). The total in this wallet ends with 275.2, so it doesn’t even end with 273.72.

  3. This Daedalus/Trezor wallet is protected with the Trezor 12 word seed phrase-not from a 24 word seed created by Daedalus. When trying to restore the wallet on another computer, Daedalus shows this 12 word restore as a Byron wallet, and restoring this way brings up an empty wallet. I guess I need step by step instructions pls on how to restore a Trezor?D wallet.

  4. I just used adulate to send 5 Ada from the trezor/D wallet to my solo Daedalus wallet. I’m guessing I’m gonna need to send all of it off this wallet and into my regular Daedalus…?
    thank you…

OK, so first up. your trezor wallet is fine and is holding your ada. It doesnt matter if you use daedalus or adalite or yoroi with your trezor device, the funds are on your trezor device, the named wallets just show what is on your trezor and give access to spend it (send transactions).

which wallet is that?! if daedalus and adalite are both connected to your trezor (we know adalite is), everything must be exactly the same. also the rewards must be the same. Maybe your daedalus wallet is nog a trezor wallet but a non-trezor wallet you created in the byron ara before you had bought your trezor wallet?

a trezor model t wallet has a 12 word recovery phrase, so that makes sense. a non hardware daedalus wallet in the byron ara has a 12 words recovery phrase too. a non hardware daedalus wallet in the shelly ara has a 24 word recovery phrase. It seems like you have multiple wallets. that is not a problem you can restore them all in daedalus side by side.

This makes sense if you started your first wallet without a trezor when we were in the byron ara. This wallet has a 12 word recovery phrase. If you later created a shelly non-hardware wallet and sent your ada to that one it makes sense that this one is now empty. Could that be the case?

You just restored your trezor wallet on adalite didnt you?

no wait. what do you mean with “regular daedalus”? I am pretty sure you have created multiple wallets. sounds like 2 non-hardware wallets and 1 hw wallet.

Lotta stuff here. First off, thank you for your time with this. Adalite was a big help. I’ll do this in steps as it is the best way for me to keep organized. First with origins, then what I’ve now done.

  1. Starting with my Shelly wallet, which had all my Ada. I then bought a Trezor T within a month, for cold storage. When you connect a Trezor into Daedalus, it doesn’t sync up with your existing Shelly era wallet, but instead creates a new Daedalus/Trezor wallet. As I’m sure you know, this new D/T wallet is protected by the 12 word seed key of the Trezor-not from any new 24 word seed key that would otherwise be created in Daedalus. I then sent a high percentage of my Ada, from Shelly wallet, to D/T wallet. For “better” protection.

  2. Now, when I went to adalite, and synced using my Trezor, and I’ve snap shotted this, the totals were the same. BUT, they didn’t show the same. What I mean is the total in adalite showed a lower balance in the balance section, but then to the right was a rewards balance-those 2 added together equaled the total balance in my Daedalus/Trezor wallet on my desktop in the summary section. In addition to that, the rewards balance of 273 Ada, shown on adalite, was different than the 314 rewards in the rewards section of the Daedalus/Trezor wallet (not adalite, but the desktop wallet.) I hope this is all clear.

Now every time I was trying to send Ada from my D/T wallet, this is BEFORE using adalite, the only send amount that would show on my Trezor device, was 273 Ada-again, regardless of how much more or less I was actually trying to send. So for some reason, the Trezor was stuck on this 273, and this happened on the second Trezor device, that I recovered to make an exact clone of my first one-so they could both be used to control the D/T wallet. So somehow there’s something off in the communication between D and T, it would seem.

  1. Adalite was a savior, and I’ve moved my Ada out of this D/T wallet, and back into the ORIGINAL Shelly era wallet, which was the one I used in the first place to send to the D/T wallet. So the question now is…

-Do I create a new Trezor synced Daedalus wallet, and keep some stored in there? I never had issues with my standalone D wallet.

-How in the heck do you restore a Trezor synced Daedalus wallet, step by step. Not on adalite, but within Daedalus. Because you have to use your 12 word Trezor seed to do this, and Daedalus calls this a Byron wallet, which it isn’t. And I haven’t seen an option where you connect your Trezor while in Daedalus, have it be detected, get asked to restore using Trezor 12 word, and start syncing. That would make sense to me. The only options within “pair a hardware wallet” are to “pair for the first time” which means you connect Trezor and unlock, which I’ve done, but the wheel keeps spinning and nothing happens. Or it says “if you’ve already paired your device with Daedalus” (which technically I have in the past to create the wallet pair) then you “don’t need to repeat this step, just connect when you need to confirm transaction.” So, unlike restoring non/Trezor protected D wallets, this process for T protected D wallets, seems not straightforward, and until I know I can do this to restore, I can’t feel comfortable using the Trezor within Daedalus.

Man I hope this is making perfect sense… :slight_smile:

You are welcome. I can imagine how important this is for you and it gives me a good feeling if i can help.

  1. And 2. Make everything pretty clear now.
    The reason why your rewards balance in adalite is lower than in the rewards section of daedalus is also logical. Adalite only shows the rewards of your trezor wallet. Daedalus shows the sum of the rewards for both your initial shelly wallet as your trezor wallet. So nothing strange here.

So sending from your trezor wallet works normally on adalite but is restricted as you say to this 273 ada. Now this is strange. What we know is that 273 is your rewards. I don’t understand this yet. But this should work normally. And no need to reinstall daedalus. Try to withdraw the rewards and the see if everything works. There is a withdrawal button in adalite.

No, your initial shelly wallet is not protected with your trezor. I would recommend using your trezor if you have one. It’s much safer and also more convenient as you saw with adalite.

No you definitely don’t need your 12 words recovery phrase if you have a working trezor with a pin. If you would take a fresh new computer, connect your trezor and install daedalus and create a new wallet, it will ask if you if you have a hardware wallet and it will just add it. Just like with adalite!

Hey Ada4Good. Thank you again for your ongoing help, delay in response from family etc. I do this a lot for others, so guess karma works:) As for the withdraw of 273, this was happening before adalite, whether trying to send to an exchange, or from the Trezor/Daedalus to the other Daedalus wallet. The correct amount would show on the Trezor, until the final screen when whatever the amount was would then change or revert to 273. you could be sending 50 Ada, all good until final screen which again was 273… This is why I used adalite to move my Ada to my original Daedalus wallet, for now at least.

So I sent the 273 and change to my other wallet, then was going to send the final 1 Ada as a test to see if Trezor final screen showed 273, but it showed 1.8 including the “gas” fee, so I din’t send as it was accurate. The real question is why was it acting up, and how do I trust it moving forward. Straight Daedalus never gave me a problem, but of course cold storage is the way. will be speaking w IOHK as well. Much thanks bro

1 Like

Hi Hilly, good to hear that at least your funds are safe even though we can’t yet explain why daedalus was acting the way you describe. Would be curious if you find out through iohk.

But to finalize, you should know that if trezor works fine via adalite, there is nothing wrong with your trezor. So i don’t see any reason why not just move everything back to your trezor and just use adalite or alternatively yoroi as the front-end.

Good luck!

Hey Ada,

Yeah, I’m hoping to find out from IOHK what the heck happened. Makes you lose faith a bit in the hardware wallet. I do know what you mean though, def like cold storage. Will lyk what they say.

Thank you again!:slight_smile:

1 Like