How to check if Stake Pool has successfully retired

Hi guys,

I’ve just retired my Stake Pool and submitted the signed transaction successfully. How do I know if the request has gone through as my utx0 balance remains unchanged. It’s only supposed to take effect in the next epoch, but would be nice to get a confirmation now so I don’t need to wait another epoch.

Thanks and regards,

S.

can you give me more info on the ticker?

you should be submitting the retirement (deregistration certificate) in transaction, so there should be some balance changes.
also, when you created the deregistration certificate, you submitted the epoch when it will be retired.

you can also drop me in a private message.

Lauris

Hi!
I’m running into the same issue currently.
I followed the docs which was clear except one thing:

The epoch calculation in the docs was resulting in 47 as a current epoch.
I used 246 as the epoch for the deregistration certificate anyways. Think the calculation in the docs is not accurate.

So I created the TX, Signed and Submitted it.
No error was shown, so I assumed it was successful.
But the balance of the Payment Address did not change.
Also I do not find my pool to be listed in the retired pools list of

What is also strange now. If I want to send another transaction from the same TX which i used to pay Fees for the Retirement I get an error:
UtxoFailure (ValueNotConservedUTxO (DeltaCoin 0) (DeltaCoin 96600000))

Any Idea what could went wrong?
Did you manage to get your retirement accepted?

Docs Link: 11. Retiring a Stake Pool — cardano-node Documentation 1.0.0 documentation

Hi there,

Seems we are in the same boat here. I’m still figuring a way to find out the retirement status of my request tx. In the meantime I will have to wait till epoch 246.

Yes the documentation regarding the epoch is quite confusing. Not sure if using 246 in the tx was wrong. If it’s less than the max then we could be waiting for awhile unless we can resubmit a shorter one.

I did find this additional documentation (check the very bottom of the page): Guide: How to build a Cardano Stake Pool - CoinCashew

Haven’t tried to send the funds out like you have. Perhaps you made a balance calculation error? Did leave enough in the uxto for the deregistration fee?

S.

This is the command I used.
Balance of the tx-in adress was (and still is) 96600000.

cardano-cli shelley transaction build-raw \
--tx-in MYTXIN#0 \
--tx-out $(cat addresses/payment.addr)+96427239 \
--ttl $(/commands/calculateTtl.sh) \
--fee 172761 \
--out-file tx.raw \
--certificate-file ../pool-keys/pool.deregistration

The following was not clear to me:

  1. When will this be executed? Straight away or when the new Epoch starts. Since my TX was not reduced I joust thought it will be executed when the new Epoch starts. But this would mean having a not-executed transaction until the start of the new epoch, which would lock all the funds in the TX-IN until then?!?
  2. My TTL Script just adds 200 to the current Tip. Does the TTL need to be higher than the first block in the new Epoch? If the TX really waits until the new Epoch I’m afraid it will be cancelled based on the TTL being lower then the current TIP at the time of execution (assumed to be the start of the new Epoch)
  3. Based on my in-ability to use the payment adress for any transaction at the moment I’m also not able to re-do the de-registration. So I’m really curios about what happened to my tx-in and causes the mentioned ledger Error: ValueNotConservedUTxO. I assume that the DeltaCoin 0 means that there is 0 balance on the TX-IN side. When querying it I get the assumed 966000000 balance.

BTW: Have you checked if you pool is in the list here: Retiring Pools | Cardano Staking
Mine is not in the list. And also if i show the Pools in Daedulus Listview it is not showing info to be retired in any future block. So to me it seems like something failed with the de-registration.
Would be glad for any Idea how to further analyse what happened!

The error is either you didn’t calculate correctly amounts or the returning amount is less that 1 ada

Finally I found out what happened.
My Node was isolated from the network (no connection to any peer).
For that reason none of my transactions was submitted.
Strange thing is that the initial retire request did not course an error.
Other strange thing is that executing any further transaction was causing a ValueNotConverved Error while querying the TXIN was still showing some balance. I would have expected both to be either 0 or the actual balance.

How did i get behind it.
just tried to run the same command on a different node.
There it complained about an invalid TTL.
So I compared my results of getting the current Tip between the nodes.
This differed. Checking the logs I found out that acutally no peer was responding.
Firewall was blocking everything :wink:

How about you?
Did your retirement finally work out?

Waiting for the end of epoch 246 to find out! Fingers crossed :slight_smile: