How to mint using CNFT Tools

hello,

I would like to mint NFTs using CNTOOLS, but I’m having an issue with the metadata and asset not displayed in pool.pm.

I didn’t find any complete tutorial about how to mint using CNTOOLS, but I could update this topic, and it will become a tutorial.

I’m doing this on a block producer node of my staking pool, which i’ve installed following this great tutorial from Alexd1985 and which is based on guild-operators scripts and CNTOOLS:

Here is what I did:

1- Activate CNTOOLS advanced Mode

Change cntools.config (scripts folder) for enabling the advanced mode.
Run ./cntools.sh

2- Create a Wallet
select “Walet” → “New” → follow the steps for creating a wallet
Sending ADA to the new wallet and validate transaction is completed
3- Create a Policy
Go back to home menu and select “Advanced” → “Multi-Asset” -->“Create Policy” → follow the steps for creating a new policy
4- Create Metadata
Upload the file which will be minted to IPFS and copy the ID for preparing Metadata with the policy ID previously crteated as below:

{
“721”: {
“replace by policy_id”: {
“NFT01”: {
“name”: “Logo01”,
“Collection”: “Final Edition”,
“Series”: “S000”,
“Id”: “01”,
“Description”: “Logo NFT Test - short”,
“Rareness”: “Uniq”,
“Artist”: “Myname”,
“Copyright”: “Copyright 2021”,
“image”: “ipfs://ipfs/QmSdwdyikmRS9iZQfGpxbFsQTKdyhfTWm4jn3fcpDjXNaS”
}
}
}
}

Go back to home menue, the “Advanced” → Metadata"–> “Online” → “No JSON Schema (default)” → “enter” → open nano editor and paste prepared metadata, exit, save → “Stop”, i didn’t continue for signing the metadata as i guess it will be done during next step

5- Mint the asset
Back to home menu:
select “Advanced” → “Multi-Asset”–>“Mint Asse” -->Select the created policy for minting → enter asset name → define number of minted tokens of this asset —> Attach JSON file = yes —> browse and select created metadata file —>Select wallet to mint assets on and cover the transaction fees → wait for it, and it is completed.

When I check my wallet, I see the minted tokens as assets and they are listed on pool.pm, but I can’t display them, hereunder is what I get:

https://pool.pm/addr1q99udd4pccgy8pj0s99sgn0an2c7wpfngkv6m64glt753xg855w6767qrpyfs6dcdvad3tkcn3295hgycqva6fjfq50qtjfm0c

Could someone please explain me what am I doing wrong, and what should I do ???
How could I correctly mint using CNTOOLS ?

I’ve tried to Rgesiter the asset minted (“Advanced” → “Multi-Asset”–>“Register Asset”), but it is requiring “token-metadata-creator” which I didn’t know how to install … ???

I get this message when i check my wallet assets:

No metadata registered in Cardano token register for this asset

I’ve tried multiple Metadata files formats, or IPFS files or structures, but I’m getting the same result.

Thanks.

Hi,

Great tutorial!

I think (I am not sure) u should register the token first

Cheers,

Thanks @Alexd1985 for the reply! I think you are right and that’s why I was talking about installing this component for CNTOOLS : “token-metadata-creator”

But unfortunately, I didn’t manage to do it, i found some tutorials using it, but not explaining how to install it.

I think the issue is in following line.
“image”: “ipfs://ipfs/QmSdwdyikmRS9iZQfGpxbFsQTKdyhfTWm4jn3fcpDjXNaS”
It should
“image”: “ipfs://QmSdwdyikmRS9iZQfGpxbFsQTKdyhfTWm4jn3fcpDjXNaS”
I could be wrong.

image

Is this any name?

Yes, a policy name which u will use later to mint the NFT

image

Hey Alex do you know how to stop and or know what is causing this?

I don’t know why this behavior (started with 1.33.x version), just press space, close the cntools and wait more minutes (usually 10-20 minutes)
I believe because starting with 1.33.x it will take longer to interogate the wallet balance… I tried with 1.33.1 and same…

This has been going since last night. Do you know how to stop the que?

press space once or twice you will see a message … anyway… the transaction wasn’t processed?

transaction was not processed and it said it will remain in the que

ok, then try this… create the transaction on hibrid mode, close cntools and start in offline mode ( ./cntools.sh -o) sign the transaction, then close cntools and start normally (./cntools.sh) and submit the transaction

should go faster

Ok, I will give that a shot. Transaction still in queue? seems conflicting… Is it aborted after I press any key? Should it read: transaction still in queue! press any key to abort!
image

Yes, should work… I tested yesterday… u know what? Thinking if it’s better to downgrade the node to 1.32.1

aaa anyway… you are trying to mint NFTs with cntools? It will not show the image on pool.pm because starting with 1.33.x you’ll need HEX name and it’s not clear for me if cntools do this… ( I spent last evening 3 hours to test but without success)
better for you to downgrade the node to 1.32.1

1 Like

This is my pools BP makes me kind of nervous … just run the update backwards?

try yourself with 1.33.0 … perhaps the output will be different for you, maybe I did something wrong for not showing the NFT on pool.pm (the image)

I’ll try offline hybrid if that doesn’t work I’ll build another relay with 1.32.1… I’m assuming the node just has to be synced not registered with my pool? Can I import a wallet from Daedalus or Yoroi and if so is that where the tokens will be sent to?

you can use one of your relays… just downgrade to 1.32. … then yes, u can import the daedalus/yoroi wallet using import option… then yes, that wallet imported will receive the minted assets… (if you will import wallet in cntools check to have funds on the first/oldest address of the wallet because cntools will only see that address from the all wallet imported)

1 Like

image

It looks like that transaction went through (I thought it was canceled) but I am not able to see it on Pool.pm or in cardanoscan. How can I examine this some more?