I don't have any IN peers and I'm not sure is my BP works properly

I have just started my own stacking pool but when I’m looking at gLiveView dashboard I’m not sure is everything working.

On my block producer, I don’t have any IN peers and mempool tx/bytes is 0/0.
On the relay node, I have some out peers (28) but I don’t have any IN peers.

Does that mean that everything works properly or not? I will very much appreciate any answears.


Check your relay port, if it seted to accept incoming connections

Also on your relay u should run the topology updater script and add your bp IP + port inside topology updater script… to “custom peer” field


Thanks for your answer,
my relay port is open ( but on the dashboard, I don’t have any incoming connections. On my BP now I have 1 in and 1 out peer (I ran updater-script with the wrong port 🤦🏻). It looks like BP is establishing a successful connection with the relay but the relay doesn’t realize that. The weirdest thing is that in a peer view I see IP that belongs to BP but on the very strange port and in unreachable category.

Can u put screenshots?
Hide Producer’s IP

Btw, u should not use topology updater script on BP, only on Relay

And also on your relay keep connections (out) around 20 ; this is the recommendation.


Thanks for your tips,
I ran topology updater on relay of course c:

Strange, because u have tx incremented which is a good status; if u start ur node with correct port and if ur IP’s were edited correct, try to restart your relay

When i restarted node with updated startup script (relay address instead ) everything stopped.

Yes, use

i think you block outgoing traffic…
on BP = you block from your bp to Relay.
on Relay = you block from relay to BP+internet IPs(to any)

How i can block, outgoing traffic? On ufw i have allow rule for used ports and my VPS provider doesn’t block anything. Is there any other way to block outgoing traffic?

there is cases, where we have firewall on node, like ufw, and also the VPS provider provides you firewall.
you just check it if is enable and if all outgoing traffic is not blocked.
then you allow incoming traffic to specific ports based on your setting.

and you should be fine

but if i may ask, why do we see a Public IP on your BP as a peer?
is the relay not running on the same LAN with the BP?

also on relay we see the BP is connecting on 42581, is that the correct port you have prepared on BP ?

please on BP

  1. check "nano topology.json, if you have the port to relay
  2. if you use cntools, on env file the “CNODE_PORT=” is the port from your BP.
  3. on cnode.sh if there is parameter with --host-addr = \ and --port ${CNODE_PORT}

restart nodes, and check again the port of BP on Relay

I checked - everything should be fine.

relay is not running on the same IP - my provider doens’t offer this option

I checked again ports and everything looks correct.

core has TXs and peer with Relay.
looks fine.

the relay needs comuniction outside.
can you send one more screenshot for the current status?




Hi Cardano Gurus,

I’m running my stake pool and facing the same issue.
My relay node has only OUT peers, but it doesn’t have any IN peers.

The ufw firewall has a default allow rule for outgoing connection and I’ve tried to disable firewall too.

ufw status verbose
Status: active
Logging: on (low)
Default: deny (incoming), allow (outgoing), allow (routed)
New profiles: skip

To                         Action      From
--                         ------      ----
22/tcp                     ALLOW IN    Anywhere
3001                       ALLOW IN    Anywhere

Both relay and BP nodes are running internally, the port forwarding :3001 to relay node configured on the router for incoming connections.

The relay node has outbound tcp connections.

# netstat -nputw | head -n 5
Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0      ESTABLISHED 2620529/cardano-nod
tcp        0      0          ESTABLISHED 2620529/cardano-nod
tcp        0      0      ESTABLISHED 2620529/cardano-nod


Any ideas are appreciated!

Thank you,


There is a problem with ur relay

Try from producer

telnet Relay_IP 3000
an also why u have on relay 61 peers out?

Limit to max 20 peers


1 Like

Hi Alexandru,

The relay is reachable from producer.

# nc -vw3 3001
Connection to 3001 port [tcp/*] succeeded!

However, I had a wrong node port defined in env file on my relay.
Instead of :3000, the relay port should be :3001.

The issue has been solved by modifying the port.

Screenshot 2021-03-17 at 14.24.07

Many thanks for your prompt support :clap: