I don't have any IN peers and I'm not sure is my BP works properly

Hi!
I have just started my own stacking pool but when I’m looking at gLiveView dashboard I’m not sure is everything working.

On my block producer, I don’t have any IN peers and mempool tx/bytes is 0/0.
On the relay node, I have some out peers (28) but I don’t have any IN peers.

Does that mean that everything works properly or not? I will very much appreciate any answears.


Hello,

Check your relay port, if it seted to accept incoming connections

Also on your relay u should run the topology updater script and add your bp IP + port inside topology updater script… to “custom peer” field

Cheers,

Thanks for your answer,
my relay port is open (77.55.210.194:3001) but on the dashboard, I don’t have any incoming connections. On my BP now I have 1 in and 1 out peer (I ran updater-script with the wrong port 🤦🏻). It looks like BP is establishing a successful connection with the relay but the relay doesn’t realize that. The weirdest thing is that in a peer view I see IP that belongs to BP but on the very strange port and in unreachable category.

Can u put screenshots?
Hide Producer’s IP

Btw, u should not use topology updater script on BP, only on Relay

And also on your relay keep connections (out) around 20 ; this is the recommendation.

Cheers,

Thanks for your tips,
I ran topology updater on relay of course c:

Strange, because u have tx incremented which is a good status; if u start ur node with correct port and if ur IP’s were edited correct, try to restart your relay

When i restarted node with updated startup script (relay address instead 0.0.0.0 ) everything stopped.

Yes, use 0.0.0.0

i think you block outgoing traffic…
on BP = you block from your bp to Relay.
on Relay = you block from relay to BP+internet IPs(to any)

How i can block, outgoing traffic? On ufw i have allow rule for used ports and my VPS provider doesn’t block anything. Is there any other way to block outgoing traffic?

there is cases, where we have firewall on node, like ufw, and also the VPS provider provides you firewall.
you just check it if is enable and if all outgoing traffic is not blocked.
then you allow incoming traffic to specific ports based on your setting.

and you should be fine

but if i may ask, why do we see a Public IP on your BP as a peer?
is the relay not running on the same LAN with the BP?

also on relay we see the BP is connecting on 42581, is that the correct port you have prepared on BP ?

please on BP

  1. check "nano topology.json, if you have the port to relay
  2. if you use cntools, on env file the “CNODE_PORT=” is the port from your BP.
  3. on cnode.sh if there is parameter with --host-addr = 0.0.0.0 \ and --port ${CNODE_PORT}

restart nodes, and check again the port of BP on Relay

I checked - everything should be fine.

relay is not running on the same IP - my provider doens’t offer this option

I checked again ports and everything looks correct.

core has TXs and peer with Relay.
looks fine.

the relay needs comuniction outside.
can you send one more screenshot for the current status?

TTS

Screen:

1 Like