I just minted NFTs by sending ada to the creator-website but when I tried again

…the transaction display of yoroi-wallet showed that I received 7.15 ADA back but without the 5 asset I minted.
When I tried 5 minutes before that, i got the same amount of ADA back, including the 5 assets.

I minted 15 more NFTs on the same website with nami-wallet half an hour before this incident occured. The creator website is definitely not a fraud!

Those must be my “lost” NFTs. But how can I get control over them?

Thanks in advance


Perhaps is sold out? Can be possible? Anyway u must contact the site creator for more details


1 Like

No, in that case I would have received the ADA I sent completely.

I found a solution myself: I used adalite with my hardware wallet and there it was. I found the “lost NFTs” in the drop down menu “assets” just like all the other tokens.

That was the first time I used adalite. Now I have used adalite, daedalus and yoroi with my hardware wallet and have to say to my big surprise that daedalus is the most user unfriendly wallet of them all.

-At least for now. Charles said something about ones Hydra comes out it will connect faster and all that but at the moment it really is a pain in the ass…


aaa ok, glade u solved it :beers:

You can check the address on pool.pm and it will show u all assets for that address

1 Like

I know! I was just irritated because it wouldn’t show up in yoroi! I saw it on the blockchain but coudn’t get it under control! Thanks for trying to help! That was very kind of you!

1 Like