IMPOSSIBLE to transfer ADA

Hello, I’ve been trying to transfer or even swap my cardano (stored on zelcore) for months but it doesn’t work! , the transaction continues to be refused, again and again, I don’t understand what’s happening, Zelcore doesn’t even respond, I tried different amounts, from 10 to 20, 30 to 87, nothing works, no matter the amount, the transaction is refused it’s driving me crazy, could a kind soul help me? :pray:

Looks like something for Zelcore support? Not familiar with the platform, but if they let you transfer to your own wallet that might be worth trying? You could get the benefit of staking that way. Lots of great wallet providers now.

I have the same problem. Zelcore support is a mass of nerdy idiots, a wallet full of bugs and…developers idiots.

hey @boh_bah , I solved the problem by my own, idk why, but the PC version of Zelcore is outdated, you have to install Zelcore on your mobile device. This should work.

no, they are bot the same, also the mobile and updated android version does the same and report the same error.And even FIO doesn’t work

hello? apart a pair of scammers idiots who attempted to steal my cardano private keys, is there anybody to solve this bug? Really this multimillionaire organisation leaves people with locked funds?? Amazing it still exists

If there were more than the @cardano-dev1 above who is already suspended and they tried to scam you in private messages, it would be good to flag the messages, so that we can ban them.

Seems to be a bug with Zelcore. I don’t know that service and don’t know anybody who uses it. Would be a question for their support. How should the Cardano community help with every single wallet/custody solution that users freely choose to trust?

Cardano dev1 and the chat scammer probably was the same person. Said that, cardano community is at least responsible, as it plays with lots of different keys, to specify which key is working in which wallet. Or, if it exists a way to convert a key format to another format. Otherwise funds are locked no matter Zelcore or whatever other bug. So, as you are so expert to make moral, please at least say me a 121-characters cardano private Key is importable somewhere, if it’s a cardano format existing or existed. Because that’s the only one I can extract from Zelcore.
Thank you

For what it’s worth: I looked into Zelcore a bit. They are a self-custody wallet app (at least they say and I have no reason to not believe them). So, your private keys stay solely on your device and their server-side doesn’t know anything about the username/password “accounts” that you create with them:


https://docs.zelcore.io/FAQ/

A wallet app mainly has two responsibilities – key management and communication with the blockchain(s). For key management, it has to derive key pairs and addresses from some root secret that the user provides. For communication with the blockchain, it either has to be the rare case of a full-node wallet app where the user’s device becomes itself a part of the blockchain network or the wallet app provider has to maintain a backend that does the communication (getting balances and transaction histories, submitting transactions) on behalf of the users.

All the wallet apps Cardano recommends, e.g., on https://developers.cardano.org/showcase/?tags=wallet use seed phrases for key management which are mostly compatible with each other. So, if one of them has problems with their backend, you can just restore/import your wallet in one of the others and be good. Moreover, multi-chain wallet apps tend to have a bit more problems with their Cardano backends for a bit longer time, because Cardano is just one of many chains and rarely a main focus. They might miss important updates, not notice downtimes or whatever.

Zelcore seems to have decided that these seed phrases are too intimidating and offers to derive key pairs based on username/password:


I don’t know if I think that that is a good idea. Seed phrases guarantee a certain minimal complexity, while in this system, nobody prevents the user from just choosing “password”. Moreover, “accounts” have the potential to elicit the impression that there could be some form of server-side helpdesk that could reset the thing, help to get access again, while that is totally not the case.

Answers to what you wrote in the meantime:

All native Cardano wallet apps use seed phrases of 24, 15, or 12 words. If you chose a wallet app that is mentioned nowhere on any Cardano website and completely deviates from the standards used here, that is unfortunately a you problem.

Your best bet is to get Zelcore to fix their backend or whatever else they have problems with.

None of the user wallet apps support something else than seed phrases or pairing hardware wallets.

You can work with key pairs directly when installing a cardano-node and working with https://github.com/IntersectMBO/cardano-addresses and cardano-cli https://developers.cardano.org/docs/get-started/create-simple-transaction.

The length of the key doesn’t say that much. Is it hexadecimal or is it in some other encoding?

The standard way on Cardano would be Bech32-encoded keys with a prefix such as root_xsk, acct_xsk, or addr_sk (but those would be 169 characters as far as I can see).

A hexadecimal key should have 32 bytes, 64 characters for non-extended keys and 64 bytes, 128 characters for extended keys. In the files used by cardano-cli they are stored in their CBOR encoding which adds two bytes header to that leading to 68 and 132 characters, respectively.

None of that is 121 characters. So, you probably first would have to find out what kind of key it is that Zelcore is giving you there and only they can tell you that. And that would also be good even if the string they give you had the correct length, since we would still have to know if we have to do further derivations on that and which or if it is to be used directly.

1 Like

well I’m not an expert like you. I don’t understand what you are trying to explain me because I am an experienced user but I’m not a developper or so advanced. So I can just picture the error message that happens trying to send. Maybe there’s a remote chance you understand why, The wallet works perfectly on receiving, but doesn’t send it.
ada

Axios is a client library that they seem to use inside their wallet app: https://github.com/axios/axios
400 is the error code for “Bad Request”: https://developer.mozilla.org/en-US/docs/Web/HTTP/Status/400

So, what the wallet app on your mobile or in your browser tries to send to the Zelcore servers is somehow malformed. That can well happen only when trying to submit a transactions, but not when reading balances and history. Looks even more like a Zelcore problem.

But could also be that, like @alexei said above, an old version of the wallet app still uses different formats that are not supported on the server anymore. Are you positively sure that you have the latest updates?

Sorry! I can’t know beforehand the knowledge, the willingness to tinker, the access to someone with more knowledge. So, I tend to try to give as complete information as possible.

You asked if we can do something with the private key you have. I can’t just answer “Won’t help!” because there is a small possibility to find something with a lot of guessing around (or getting answers from Zelcore) and it will be a lot of guessing around since that does not seem to be one of the private key formats usually used on Cardano.

But unfortunately you will either have to do that yourself or find someone you really, really trust to do it for you. You don’t want to give private keys (even if you/we don’t know what to do with them) to someone else. Some users have the resources – time, curiosity, basic command line and script knowledge, … – to try and even have something like fun with it, some don’t. Just take the previous post as an impression of what tools would possibly be needed to try. No judgement at all if that’s not your cup of tea, but I can’t change it.

Alternative is to bug Zelcore support, look if there really is no update that fixes it, wait if it is somehow resolved by itself.

1 Like


The problem is this is really a Zelcore issue. What is this 2 separate salted hashes unique to Zelcore? Only Zelcore can answer that. The only way you can recover funds is through Zelcore as this really is not a Cardano wallet issue. Cardano wallet API’s are all open-source so if there’s an issue anybody can refer to the source code to find the issue.

That’s really not correct. As I already mentioned Cardano API’s are all open-source and yes it is responsible but you’ve used a third-party app outside of Cardano so the community can’t be responsible for that. Also there are no different keys - different addresses yes - but there is only one unique key to a wallet.
I really would suggest to get back to Zelcore. Your 121-character key is not a valid cardano key but a key generated by Zelcore algorithms and Zelcore is the only one who have knowledge of these.

well tell me if the transaction fee should too low, if the transaction is immediately rejected from Cardano network or not. I have a suspect, and that stupid wallet obviously can’t allow to modify the amount of the fee.

It is not about the fee. The Zelcore wallet is not recognised by the Cardano network as it is not a valid Cardano wallet address. Cardano wallets are not made up of a the hash of username and password as described by Zelcore for their own wallet. Cardano wallets are generated with the cardano-wallet API. There’s no one here in the forum who can help you with the Zelcore wallet as they didn’t use that API. You have to contact Zelcore directrly to fix this.

That does not make much sense.

The Cardano network does not care at all how key pairs are derived. You can derive them as Zelcore does it. And the blockchain itself does “recognise” such key pairs/addresses. From the point of view of the blockchain they are just as valid as any other key pair or address.

They are “just” not compatible with any other wallet app. But that has nothing to do with the Cardano blockchain or network.

I think we’re talking about something completely different. Of course Zelcore would need a Cardano wallet with Cardano API to keep the ADA tokens but to access that wallet they use their own username - password hash plus some in-house algorithm and they are the only ones to have keys on those hashes.

After days and days spent writing emails, downloading the entire Cardano blockchain through Daedalus Wallet and trying to tinker with everything with multiple attempts, for now I have come to 3 conclusions: 1, the developers and online support of Zelcore Wallet must having left their brains in the cellar or smoked it with hard drugs; 2. the developers of Daedalus Wallet are so ingenious that they only provide the “send” button and not the “receive” one
3. I hope that one day ALL Cardano accounts will be blocked NO KNOW HOW AND WHY’, it could be funny to see a marketcap over 16 billions dollar completely locked

  1. 2 multiwallets, both with ada locked sending, so it’s a cardano problem unless all the developers of both wallets are poor

Which second one do you mean? There for sure have been second ones in the past, but none were mentioned here as far as I can see.

And how is it a Cardano problem?

The blockchain can do nothing against someone inventing an arbitrary way to generate key pairs and use them.

The ecosystem has standards and a lot of talk about how to use them right to stay compatible with each other.