Installation Dependency Errors

Hi All -

Trying to build out a stakepool server on linux following the Stakepool School documentation here:

Works swimmingly until I get to building the cardano node - after running “cabal build all” it fails with:

$ cabal build all
Warning: Requested index-state2020-07-15T00:00:00Z is newer than’! Falling back to older state (2020-07-14T22:50:55Z).
Resolving dependencies…
cabal: Could not resolve dependencies:
[__0] trying: lobemo-scribe-systemd- (user goal)
[__1] next goal: libsystemd-journal (dependency of lobemo-scribe-systemd)
[__1] rejecting: libsystemd-journal-1.4.4 (conflict: pkg-config package
libsystemd==209 || >209, not found in the pkg-config database)
[__1] rejecting: libsystemd-journal-1.4.3, libsystemd-journal-1.4.2,
libsystemd-journal-1.4.1, libsystemd-journal-1.4.0, libsystemd-journal-1.3.4,
libsystemd-journal-1.3.3, libsystemd-journal-1.3.1, libsystemd-journal-1.3.0,
libsystemd-journal-1.2.0, libsystemd-journal-1.1.0, libsystemd-journal-1.0.0
(constraint from project config TODO requires >=1.4.4)
[__1] fail (backjumping, conflict set: libsystemd-journal,
After searching the rest of the dependency tree exhaustively, these were the
goals I’ve had most trouble fulfilling: libsystemd-journal,

Thanks in advance for pointers in the right direction.


have you tried running cabal update prior to the build?

what flavor of Linux are you running?

here is a reported issue which aligns with what you are observing specific to CentOS:

Expected behavior
cabal-install will not require systemd-devel package to resolve dependencies and build.

I have reached out to Mark (who reported the issue) to identify a remedy, but offhand it seems you might be able to get around the issue by installing the systemd-devel package

I’ll ping back here if / when I learn more.

EDIT - I have confirmed you will just need to install the systemd-devel package

1 Like

Heya - thanks for answering. Using the stock AWS linux AMI (under Lightsail). And I did update Cabal just after installing it as the instructions state to do here:

As for the systemd-devel package, “No package systemd-devel available.”

I’ll try rebuilding this with CentOS and report back

Ok, CentOS seems to have done the trick - not sure what’s up with that AWS Linux AMI.

Also, as soon as I got into the server via ssh, I ran the following.

yum -y groupinstall Base “Development Tools” && yum -y update

Once that finished up, the rest of the installation ran smoothly.

Thanks for the assist!

1 Like

I’m sorry, can someone explain what is the solution for this problem? I’m having the same issue in my AWS Instance.

Thank you,


@ADAfrog @Gavster

Hi guys, could someone please help me resolve this issue?

Thank you,


Hi Matias,

Did you try the steps above? What linux distribution are you using?

You need to install the systemd-devel package to resolve this error.

Your friend, FROG


You were right. That fixed my issue.

Thank you so much,