Known Issues on Daedalus Following the Cardano 1.5.0 Release

An issue has been found in the latest release of Daedalus 0.13.0 (Cardano 1.5.0) which is affecting a small number of users.

The issue is with the spending password not being recognized, even though it is has been set for a wallet. It is preventing users from spending ada because Daedalus is not asking for a spending password when a transaction is created.

The issue is affecting only users who have skipped the previous major release of Cardano and who have upgraded directly from Daedalus 0.11.x (Cardano 1.3.x) to Dedalus 0.13.0 (Cardano 1.5.0). It is not affecting users who have upgraded from Daedalus 0.12.x (Cardano 1.4.x) to Daedalus 0.13.0 (Cardano 1.5.0).

The issue has been confirmed and the fix is in development. Users who are affected by this issue will be able to upgrade to Daedalus 0.13.1 (Cardano 1.5.1) shortly and are kindly asked to look out for updates soon.This issue is just a temporary inconvenience and is not posing any additional security concerns. This thread will be updated with new developments.

20 Likes

After having tested my 12word backup phrase for being correct (there’s a description how to do on the forum I found), I removed the wallet and with backup phrase reinstalled the wallet again.
To me that solved it. (But just learned about an update shortly I afterwards would have waited for that instead of finding out if a backup works…)

3 Likes

Did the same process with the same positive result.

2 Likes

This is kinda strange that a bug like that slipped through. I specifically asked the question about upgrade dependencies from 1.2, 1.3, 1.4 prior to 1.5 in the podcast Episode 20. Maybe the testing and QA process needs improvement to prevent this type of release error. I’m glad it got caught quickly after release.

7 Likes

Tom,

Since I upgraded my Daedalus wallet to version 0.13.0, the Cardano node crashes when I go to open the wallet. How is this problem resolved? I tried going to network status and restarting, but it isn’t working. I am using windows 10. I would appreciate help. Thank you.

Hi There,
Could you report in community techsupport group, so we can look at logs and suggest actions accordingly?

1 Like

Is there TDD in place?

Hello Tom,

Thanks for info.
So, Waiting for fix.

Yves

@yvescharlestouzot, its already available

1 Like

Hello Tom,

Any more news as I’m not recovering my Deadelus, yet.
Even following very carefully following procedure :

Delete the DB-1.0 and the Wallet-1.0-acid folders

Windows

  1. Reboot your machine to ensure Daedalus is not running
  2. Type %appdata% on the explorer’s search bar, or alternatively go to:
    *C:\Users[your user name]\AppData*
  3. Locate the Roaming folder and open it, find the Daedalus folder and open it.
  4. Locate the DB-1.0 folder and delete it. Note that this folder contains over 1.5 million files so this delete operation could take hours.
  5. Once the folder is deleted, empty the trash.
  6. Locate the Wallet-1.0-acid folder and delete it.
  7. Reboot your machine
  8. Start Daedalus and allow it to Sync. Note this will take several hours since the blockchain is large (over 15 Gb as of October 2018).

All my thanks

Yves

Hi @yvescharlestouzot,

Do you have the latest version from daedaluswallet.io?

Hello Andy,

All my thanks for your care.

DAEDALUS (0.13.1#3.0.12940) so that you may check which version I have.
Almost not connecting from 08/18 to 03/19. So, maybe, missed a major update.

All my thanks for your help.

Yves C. TOUZOT

@rdlrt could you help this person out? Many thanks in advance :)!

1 Like

Hi @yvescharlestouzot,

Could you join the community techsupport on telegram, so that we can discuss and suggest next actions (this may include sharing logs).

Hello,

All my thanks for your proposal.

A lot to do this week.

Going to do it next week.

Yves

Update: Resolved on telegram.
Summary:

  • The 12 seed words he had were incorrect (possibly wrong order), so Yoroi was not easily an option without some guess work.
  • Daedalus he had was in sync but had a single wallet with 0 balance. This might have been due to the fact that Wallet-1.0-acid was deleted as per IOHK support page instructions that he followed.
  • Used the Wallet-1.0-backup* folder that is automatically created when upgrading from Daedalus 0.11.2 or before to restore his wallet.
  • He was able to see his balance then and tested an outgoing transaction, works alright.
1 Like

Hi @tom.kelly

Any update? I have v1.5813 and my sync has been stuck to 68% for days.

Thanks,
D

Tom’s no longer around. Are you on Telegram? That’s the best place to get help these days. https://t.me/CardanoCommunityTechSupport or @CardanoCommunityTechSupport