Ledger get stuck on “waiting commands”


I just received my ledger and trying to figure things out to begin staking my coins.

Is the “waiting for commands” a normal status on the ledger or should it say “application ready” like the other apps? Every time I enter the cardano app on the ledger it stays on “waiting for commands”.

1 Like

Do you have Ledger Live open in the background? If so close it and try again.

Its normal to have waiting for commands. You need to open Yoroi, Daedalus or Adalite and do transaction (delegate or send) from there.

And then it will change for waiting for commands and showing you how much ADA do you wantto send, transaction fee, target address, etc.

Hope it helps.

This helps, Much thanks!

1 Like

Hi I am having the same issue. I just updated my Daedalus wallet to the latest version, and it is connected to my Ledger. When I try to “Send” from the Daedalus wallet, my Ledger says, “Waiting for Commands” and I can’t send. Do you have any suggestions?

1 Like

You have to close Ledger Live if its still open in the background.

Also make sure your are using the most recent ledger firmware and Cardano app on your ledger device.

1 Like

I updated the Cardano app in Ledger and it fixed the problem. Thanks so much Zyroxa!


My Cardano app on ledger was already up-to-date, and none of the suggested troubleshooting steps were working. I uninstalled the Cardano app on ledger, then re-installed, and it worked. No version change or anything, but it did the trick.

Then perhaps u didn’t told all the story… this is happening when u are changing/restoring the device

I got the same problem after replacing my first ledger Nano S with my second (screen problems). I can access my crypto on ledger live again, even Metamask and making transactions on ethereum mainnet works, but I somehow cant connect my new ledger with my old ledger protected wallet on Daedalus. Ledger firmware is updated, cardano app is updated.

Am I missing something? Anything i could do to make my Daedalus wallet work again? Thanks in advance

I think u will need to delete the the old wallet from daedalus and pair the new ledger again

!!! Before to delete the wallet check/verify that the funds are on ledger - connect the ledger via adalite.io and check the balance!!!

Thank you for the response Alexd
Balance was still on adalite.io, so thats fine.

However, for some reason i cant connect both my old (still a bit functioning) and new ledger to Daedalus. So i cant pair the new ledger again… Any other suggestions? Both my ledgers got the latest firmware and latest cardano app version, reinstalling the app didnt work neither

Thank you in advance!

If your using a VPN try disconnecting and close all other applications running.

Thanks for the suggestion MTLOZ. I am not currently.

EDIT: managed to re-pair my wallet in Daedalus with my new ledger and all fine now. Thanks!

I had the same issue using Daedalus and Ledger, however my problem was an inferior micro-USB cable. I swapped the cable with a high-quality replacement and my ledger was working again. I noticed that with the faulty cable, when I unlocked my device, Windows did not register the USB device. You know, the sound you hear when you plug in a USB device? After replacing the cable, Windows registered the USB device (and made a sound) as expected when I unlocked the Ledger. Hope this helps.

Unfortunately my wallet doesn’t connect with Ledger. I can’t make any transactions.
I only have IPhone. YOROI app is connected with Ledger.
The attachment shows the error. Already tried updates and Bluetooth refresh pairing. Ledger company is not answering…
Could someone help me or had the same problem?! Thx!


1 Like


I have managed to SOLVE this problem… This is what you do:

  1. Install Yoroi extension on Brave Browser
  2. Open Ledger Live and connect your Ledger
  3. Uninstall the ADA application by going into Manager
  4. Now go to Apps and reinstall the ADA app
  5. Close Ledger Live
  6. Restart the Brave browser
  7. Open Yoroi and go through the steps of connecting it to Hardware Wallet (Ledger in this case)
  8. Works like a charm
  9. Now this will also work on other browsers like CHROME…

Enjoy and share your feedback if it works for you. :slight_smile:

After the cardano app remove/install do u see another version?

Yes. It drops a version and that’s why it works… ver3.0.0 has some problems I guess

1 Like