Ledger "Waiting For Command" error

After setting up my Yoroi wallet with my Ledger device a while ago, I have now deposited ADA into the wallet but can’t delegate or send as it can’t get Ledger approval. Ledger displaying “waiting for commands.” Pressing 2 buttons as suggested in Yoroi FAQ didn’t help so it said to come here for assistance…

Try to close the yoroi, then disconnect the ledger, connect again… and after that open yoroi…
Other people replaced the cable to fix this issue, try to change the usb port ort replace the cable…
One more thing… u will need to choose your ledger device from that popup (try to restore the wallet → open yoroi → add wallet (shelley era) → connect ledger)
If still not working connect the ledger on adalite.io (it’s secure) and delegate from there…


Thanks for your swift response.

I have tried all the close, disconnecting and even reinstalled the Ledger Cardano app.

The cable works fine for all my other accounts/tokens.

Got it working on a different browser. Strange I could set up on the previous browser but then it wouldn’t function.

1 Like

exactly changing the browser also can fix the issue, I forgot to mention :slight_smile:
If you are looking for a great project/pool you can check mine :stuck_out_tongue: