[Linux] Daedalus "Connecting to the network..." (ArchLinux)

daedalus

#1

After I succesfully installed daedalus cardano-sl packages on Archlinux :
(Here are my instructions what I had to do to build it : https://gist.github.com/gwpl/0e4a3ae4d4e21e429b324808cdca3e46 ),

I run

$ daedalus
(...)
[23:02:25:0209] [error] CardanoClientApi::syncProgress error: {
  "stack": "Error: connect ECONNREFUSED 127.0.0.1:8090\n    at Object.exports._errnoException (util.js:1022:11)\n    at exports._exceptionWithHostPort (util.js:1045:20)\n    at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1090:14)",
  "message": "connect ECONNREFUSED 127.0.0.1:8090",
  "code": "ECONNREFUSED",
  "errno": "ECONNREFUSED",
  "syscall": "connect",
  "address": "127.0.0.1",
  "port": 8090
}
[23:02:26:0148] [error] CardanoClientApi::syncProgress error: {
  "stack": "Error: connect ECONNREFUSED 127.0.0.1:8090\n    at Object.exports._errnoException (util.js:1022:11)\n    at exports._exceptionWithHostPort (util.js:1045:20)\n    at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1090:14)",
  "message": "connect ECONNREFUSED 127.0.0.1:8090",
  "code": "ECONNREFUSED",
  "errno": "ECONNREFUSED",
  "syscall": "connect",
  "address": "127.0.0.1",
  "port": 8090
}
[23:02:27:0209] [error] CardanoClientApi::syncProgress error: {
  "stack": "Error: connect ECONNREFUSED 127.0.0.1:8090\n    at Object.exports._errnoException (util.js:1022:11)\n    at exports._exceptionWithHostPort (util.js:1045:20)\n    at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1090:14)",
  "message": "connect ECONNREFUSED 127.0.0.1:8090",
  "code": "ECONNREFUSED",
  "errno": "ECONNREFUSED",
  "syscall": "connect",
  "address": "127.0.0.1",
  "port": 8090
}

When I try to connect manually to 127.0.0.1:8090, it does not work :

$ wscat -c ws://127.0.0.1:8090
error: Error: connect ECONNREFUSED 127.0.0.1:8090 

I’ve found notes about:

./scripts/build/cardano-sl.sh 
./connect-to-mainnet

However, they are not available in packages:

$ pacman -Ql daedalus cardano-sl | grep 'connect\|cardano-sl.sh' | wc -l
0

And see on screen “Connecting to network…”.
What have I missed?
Should I run manually node separately?
(Maybe sth is missing in packages I use)
If so, could you please add this to daedalus FAQ section with Linux note?

(Cross-linking, my related post on reddit: https://www.reddit.com/r/cardano/comments/75fsdv/eta_on_linux_wallet/dre7inx/ )


Availability of daedalus wallet for linux system
#2

Update:


#3

Hi,

I have had the same problem on Archlinux but I have somewhat solved it… well more of a workaround really.

First of all are you running simultaneously cardano-sl, daedalus and the middleware/bridge software?

Personally I have to run each of the following in a different terminal:

cardano-sl/./connect-to-mainnet 

daedalus/npm run hot-server

daedalus/npm run start-hot

Then I get stuck on “Connecting to network…”, just like you.

And to pass that I have to disable IPv6 in /etc/hosts, commenting out:

#::1 localhost.localdomain localhost

As soon as I save the file, I’m through and the wallet loads.

However the next time I want to open the wallet, I have first to re-enable IPv6 in /etc/hosts:

::1 localhost.localdomain localhost

Otherwise I get stuck on “Syncing blocks…” forever.

So I basically have to do the steps of enabling-disabling IPv6 every time I want to use the wallet, not very convenient but still better than a Windows wallet if you ask me :slight_smile:

I don’t know if this is only happening to me but I hope that helps others and that maybe a dev will find that useful too.


Another infinity CONNECTING TO NETWORK... post