Another infinity CONNECTING TO NETWORK... post


#1

I literally should give up on this Daedalus wallet and wait for the market to take my investments!
I’m quite a technical guy and really have no idea with what I’m dealing with a couple of days now. I try everything that I can find on Google with no success.

Such project with such smart people could do some site with online storage of our :ada: like MyEtherWallet is!

I’m not a coder so, if anyone can take a look @ these screenshots if he’ll spot some obvious glinch in there?








#2

I have experienced something like what you are.
Try to backup daedalus folder (rename it), uninstall and then install it again.
After the installation, take two folders: secrets and wallet0 and replace at the new installed daedalus. (Delete the folders from installation to avoid mixing files).
Then fire daedalus again. It worked for me


#3

But the thing is I didn’t manage to open the wallet ever…From the time I hear about the Daedalus for the firs time, I only see this blue screen with a bull :slight_smile:

I’ll try your option and I’ll let you know…

Thanks for your time :wink:


#4

Did you delete all the maps in there “DB-1.0” “GPUCache” “Logs” “Secrets-1.0” “Wallet-1.0” ?


#5

looks like something on your computer prevents daedalus.exe connecting to the cardano-node

what can you see in a web browser when you try to open http://localhost:8090 while daedalus is started an waiting for network connection?

it should be
This server only accepts secure HTTPS connections.


#6

Nope… I get this…

This site can’t be reached
localhost refused to connect.
Search Google for localhost 8090
ERR_CONNECTION_REFUSED


#7

No, just kept the old ones because i do have some adas there. But if you dont… no need then


#8

Do you have another computer you can try on the same network? After I found that my tablet ran Daedalus fine I stared looking for possible hardware/software conflicts on my computer and found the problem (a service for my killer networks nic).


#9

ok, this is an important information.
FYI, the current infrastructure is this

What: 7 main nodes (stakeholders)
Where: Internet (Amazon AWS)
TCP Port: 3000
^
|
v
What: cardano-node.exe (full node running in background)
Where: your local PC
TCP Port: 8090
^
|
v
What: daedalus.exe (visible wallet)
Where: your local PC

If you local daedalus.exe can’t reach the local cardano-node.exe and your task manager shows the node running, this means that either something already run on port 8090 on your PC (@merlot mentioned a service for the killer networks ethernet hardware) or that a local security suite (AV-Engine, Firewall, …) block access to localhost:8090
INstead of the build in task manager you can use Microsofts Sysinternals Process Explorer (https://docs.microsoft.com/en-us/sysinternals/downloads/process-explorer)
You have to start it with administrative rights. then right click cardano-node.exe, swith to TCP/IP tab and confirm that a local address is “LISTENING” on port 8090


List of port numbers for all Daedalus processes?
#10

Unfortunately just one with Linux on it. So no go.


#11

hmm, your screenshots didn’t look like linux.
Anyhow better: https://www.tecmint.com/find-out-which-process-listening-on-a-particular-port/


#12

Ups sorry…I mean That I own another one with Linux.


#13

Have you tried disabling IPv6. I’ve had the same problem on Linux and disabling IPv6 worked for me.
See this post:

I know you are on Windows and I don’t know how you disable IPv6 there but it shouldn’t be too hard to figure out.
Also I remember seeing people on Mac having a similar issue with IPv6.


#14

hey guys, had no luck with VPN or system time change/adjust, but it seems running daedalus.bat as Administrator fixed the issue.
after syncing blocks 1-2 mins, it connected.

hope it helps!


#15

Still don’t see port 8090 anywhere? This is what I get.

The red marked one 8080 is established for 30 sec but then disappears.


#16

I did turn IPv6 off but still no success.
You said you are on LINUX? How can I install Daedalus on Linux if there is no download button on official site.
Did you get it it from Github?


#17

Yes I downloaded it from github… and then spent about 5 days working out how to compile from source. The info page on github is pretty rubbish and doesn’t explain half of what’s needed to do.

If you are on Ubuntu/Debian you’ll find some valuable information here:


and here:

I’m on Archlinux, so I had to adapt the above slightly but finally I got it to work.


#18

this (dis)appearing red entries are normal and ok.

What seems missing on your side is this one I marked yellow
2018-01-06_17h18_18

It looks like something else already is listening on this port on your PC and so cardano-node.exe can’t bind to it on startup.

Can you start TCPView from Sysinternals Suite. I assume there will not be this red market item

If not try to sort by LocalPort column and look for port 8090 and what process is running on it.


#19

I did not handle with any ports, just running daedalus.bat opens the wallet easily.


#20

Most of the people don’t have any issues. But there are also many of us that get rejected py some port problems. We investigating now :wink: