Loosing my socket file

hi guys, im running the final steps for my pool’s registration. ive been following the coin cashew guide, and im on the “verifying stake pool operations” page. Im running into a problem where if i run the following command it returns the following:

cardano-cli query stake-snapshot --stake-pool-id $(cat stakepoolid.txt) --mainnet
MuxError MuxBearerClosed “<socket: 11> closed when reading data, waiting on next header True”
cardano-cli: MuxBearerClosed “<socket: 11> closed when reading data, waiting on next header True”

whats interesting is as soon as i run the command my socket file vanishes, i have done this 3 times now and everytime im having to restart the node to re build the file. Id appreciate any help as im very clueless as to whats going.

Not really a clue, but an answer will also bump your question. :grin:

I see that you aborted the first try of cardano-cli query stake-snapshot. Maybe, there’s the problem?

It could be – if cardano-cli and cardano-node are not very robust, which I totally think is possible – that the node still was putting the answer to your first call into the socket (which would be somehow consistent with closed when reading data. If they are even less robust, sending the same query again through the socket at that point could kill the node.

1 Like

Your node might be crashing. Have you got enough RAM/swap file?

1 Like

Hmm, I do, I’m running 32GBs of RAM, so unless its using more then that, (most recently checked leadership scheduled and coin cashew advises that RAM usage for running node and calculating leadership is 17GBs). I’m going to monitor my RAM usage next time iIm synced up and run a leadership check to verify RAM usage.

yes so after watching usage during a cli command, i watched the ram usage go from 16GBs to 34.5GBs (only a tiny bit more then what coin cashew was saying it would be lol). i increased the swap to 10gb from 2 and now shouldn’t run into it again. thanks for your help guys!

1 Like