Missing ADA on Yoroi

Hi, so i have some ADA missing.

I transferred from an exchange on Nov 28th 2019 to Yoroi and had it there for the snapshot to participate in the ITN. I could not get it working with the ITN however so i did not participate.

The ADA was in my Yoroi wallet until the Byron Reboot on chrome extension, i had deleted and restored before so i know the seed works. When i tried the restore function before the reboot Yoroi would ask for a wallet name and if you entered it incorrectly it would show the wallet being empty.

This was experienced by other users too as seen in the below post, response by “KidCurry” he had the same issue.

I know the wallet name does not have any function on the chain, but how come a new wallet can be created with balance of zero with the same seed but different wallet name? Is this an issue on local storage data of the wallet for Yoroi?

After the Byron reboot the ADA balance in my Yoroi went to zero. I tried to restore using the seed and wallet name but it did not work.

I am wondering is for the reboot the chain wrote over my seed with the other wallet i created under a different name.

The checksum matches also and when i check the Cardano Explorer the ADA is still in the addresses so has not be hacked and transferred.

I know some will say this is impossible but it did occur or something like it. I only ever had one seed and am adamant some glitch has occurred. I contacted support but heard nothing.

I have been reading everything on the forum, reddit and can not find any information.

I have tried to be as clear and concise with my problem and any help would be appreciated.

Also i do not have a hardware wallet.

but how come a new wallet can be created with balance of zero with the same seed but different wallet name? Is this an issue on local storage data of the wallet for Yoroi?

As mentioned on other support channels, it is NOT. Just to jot down:

  • You’re restoring Byron wallet and selecting Byron
  • You do not see an outgoing transaction, neither do you see the same address in Receive tab that matches the balance. Master seed to Address is pretty much a litmus test for your wallet assuming your wallet era are the same (you do not even need wallet software to match this bit).
  • This confirms that your wallet is different (as you agreed too).
  • Explorer confirms that your funds are on original address.

After the Byron reboot the ADA balance in my Yoroi went to zero.

Byron reboot was update for certain node softwares and would not cause any change in your wallet funds , as you confirm on explorer.

that is not how blockchain works , your seed is nowhere except your computer - in encrypted format. Please read more about how private keys work here

Every time someone has such a case , they’re adamant - usually , after heaps of back and forth - we usually find them realising they had a seperate key (eg: ledger / paper wallet / different key that was available elsewhere OR they were looking at different era wallet - you’ve confirmed that you never use a hardware wallet, so that’s one less consideration for you). You can beat around infinite times that the issue is elsewhere, but it would help yourself better if you concentrated on keys and era. I am not writing this to prove you wrong , but just hoping to get your focus beyond the impression that ‘something changing on protocol changed your seeds’ .

This is especially commonly seen when folks come back to their wallets after a few months, and there are details that we miss out on. Coming to troubleshooting actual issue:

  • you mentioned you were using Yoroi wallet on 28th Nov 2019, so I assume you have a 15 word seed.
  • You said you never participated in ITN/Shelley, this suggests your wallet would be in Byron era. Thus, the address that you’re searching for in explorer would start with Ae2…
  • Could you clarify if you were using Yoroi Mobile wallet or chromium extension?
  • When / How was the last time you checked your funds?
  • What is the last transaction date seen in explorer?


Thank you for your response, i appreciate you taking the time. I am new to posting in the community but have been a reader of the forum, Cardano Reddit and investing in ADA for 3 years. I myself am an aerospace engineer and currently working on developing new battery tech. The reason i mention this is because i can understand complex systems and have thought about this problem of my lost ADA for many months now.

If i truly lost the seed i would just accept it but i can only go by my actual experiences of what happened and work back from there.

This does not explain my experience that when an incorrect wallet name was chosen a wallet opened with a value of zero. (experienced by more than just myself). Can we just assume this is possible for a second and have a think of the possible mechanism behind this.

Also after spending the last couple of days reading about BIP39 and my understanding is that the binary seed that is built from the BIP39 mnemonic phrase can have many accounts and addresses. By adding a passphrase/multiple passphrases a new wallet is created under the common seed however the right passphrase needs to be entered to to access the right accounts otherwise a value of zero will be shown.

Also this is a quote from BIP39 specs:

“The described method also provides plausible deniability, because every passphrase generates a valid seed (and thus a deterministic wallet) but only the correct one will make the desired wallet available”.

and to quote the ledger wallet

“* Each different passphrase unlocks a unique set of accounts . You can use as many passphrases as you like.”

So saying the it (wrote over) was incorrect of me to say, rather i believe the ADA still exists with the seed however the account it is in may not be accessible. Hence the matching checksum.

Please correct me if i am wrong.

So my questions are,

How does Yoroi use passphrase functionality of BIP39 or does it not use it? Is it the spending password and gets replaced every time we restore?
Could this have been a local storage issue with the way Yoroi creates and stores key files?

And to answer your questions:

  • Yes i select Byron
  • No Addresses in send or receive
  • Yes funds are in original address.
  • Yes it s a 15-word seed
  • Wallet is Byron Ae2…
  • I was using chrome extension.
  • I checked prior to reboot via the yoroi extension when the funds were there and alot since then unsuccessfully in Daedalus, Yoroi and ADAlite.

Sorry about delayed response i had to take time to better understand BIP39.

Thanks in advance,


Again, that’s not possible - You can try it out yourself by creating new wallets. But I guess that wont help you until you find the funds, so I surrender on that part :slightly_smiling_face: .

Spending password is an encryption done locally, after generating seed from mnemonics. It is generated based on password you type, and the seed is not impacted by what you add for Name or Password.

That’s plausible deniability provided by Ledger, it’s not something supported yet in Cardano - but it will be soon. Again, it’s something not relevant to your issue, but the fact that you went to ledger website just makes me want to ask you again - you’ve never used a hardware wallet or a paper wallet before, correct?

Nope, as mentioned earlier, your seed to Wallet addresses does not even require Yoroi wallet, and can be checked independently. You can restore the same wallet using same seed in https://adalite.io for example. Not seeing transactions would mean it’s an empty wallet that was never used.

This occurred on a previous version of Yoroi and does not work anymore. I know you are not going to budge on it being possible but it happened. Whether or not a new wallet was created or another instance under them same seed or whatever. Something definitely occurred.

It is actually a base function of the BIP39 seed derivation just supported by ledger. The only reason i quoted ledger was to show the possibility of having different wallets under the same seed. Again i have not used paper or hardware.

Is it possible to find the date a wallet was created from the explorer?

The amount i have in there took me 3 years to collect and i by no means was careless with my mnemonic.

Is there a way of checking the seed against an earlier version of the chain?

Just check again and the last transaction occurred at 11/28/2019 6:33:11 PM

As I suggested, multiple accounts is not support ‘yet’, and will be supported soon - it does not relate to your case.

You can find transaction in explorer. But wallet in itself is not “created”, you’re essentially provided a set of mnemonics and “create wallet” essentially just derives wallet from it. All of this is mainly mathematics, and not on blockchain yet.

Seed has got nothing to do with chain, to match your receive address (again, you can query the walelt using https://adaite.io as well if you’d like to). Your focus needs to be on finding a different set of seed instead that provides you the Receive Address that matches your funds :slightly_frowning_face:

I do appreciate you attempt to solve my issue and once again i do not believe this is the issue and will continue until i can find an answer. I have used other wallets to query with no success.

Yoroi uses icarus right?


" Icarus master key generation style supports setting an extra password as an arbitrary byte array of any size."

This is done using PBKDF2, as seen in the script also mentioned in the following under master key generation:

These articles suggest that the use of passphrase for BIP39 derivation is being used in Yoroi through icarus with PBKDF2. With this comes the possibility of creating separate accounts/passphrases under the same seed.

When you say it ids not supported, then either this documentation is outdated or they have not been implemented.

You’re mixing different project, implementations, and status - Yoroi is an HD Wallet which did not have multi - account support as of now available to end users (spending password it uses is completely different to what you’re trying to look for), no matter which external codebase you try to use :slightly_smiling_face: .

Regardless, I think me proceeding on this thread will not help uncover any new information that I havn’t already mentioned above, thus I will surrender. Wish you the best and sincerely hope you find/can access your funds.

Ok, i am sorry i am still getting my head around it all and hope someone else can jump in too.

Yoroi is/was a icarus style HD wallet? Correct?

From the code for Masterkey Generation for Icarus style wallets a passphrase is included, is this the spending password or root key encryption password?
I understand that end user availability is not there but the core function is there.

I want to know if there was/is any possibility at all that somehow two MasterKeys were created under the same seed by accident. This is literally already an included function under BIP39 just not available to end users yet as you say.

How is the root master key is encrypted on local storage by Yoroi?

I have a Cardano node running is there another way i can query the seed?