Multiple Daedalus Wallets, One Ledger Nano S?

Hi Cardano Friends,

I have finally created a hardware wallet using my NanoS in Daedalus, transferred some funds to it from my old wallet, and staked them. All good!

My question, before I just dive in and try it: Can I create another seperate hardware wallet in Daedalus using the same Nano S? I have two distinct amounts of ada that I need to keep seperate, but I would like both of them to enjoy the security of a hardware wallet.

I hope all is well for you all and I look forward to your advice.

Cheers,
D

Yes, use different passphrase for each wallet
But don’t forget to bkp the passphrase for each wallet

1 Like

Oh Alex, how did I know that it would be you with such a useful answer so quickly?

You’re awesome!

Cheers,
D

1 Like

thanks, anytime… to much free time for me I guess :))

Oh Gosh,

I created an extra passphrase on my Ledger, created another PIN and wrote down the extra word on my seed phrase card.

Today I realised I had to redelegate. When I went to do it by typing in the PIN associated with the new passphrase, Daedalus doesn’t recognise it. It simply says "Connect the device and enter your PIN to unlock it. When I do so my Ledger just says “Waiting for commands”. Daedalus just spins its wheels and keeps asking to connect the device.

I’m beginning to feel anxious that I have lost control of my funds!

Any ideas anyone?

Cheers,
D

try to follow this order:

  • connect ledger
  • start daedalus

Hi Again Alex,

Well that made some progress. Now Daedalus is asking for me to “Export my public on my device” but the Ledger is still waiting for commands.

I’ll keep trying. We’ll get there.

Ta,
D

1 Like

Try with another cable if u have, or in another USB PORT

Yes, I will do those things. That was my next method, jiggling cables and saying “Why aren’t you working?!”

BTW everything works fine on my first wallet with my original PIN number. It is the second account that seems to be troublesome.

I’ll keep trying.

Cheers for your help Alex,
D

1 Like

Ok, an update:

I have checked USB and cables - I can make transactions with Account 1 no problem. I close Daedalus and restart the Ledger with my Second account PIN. I go to make a transaction and Daedalus asks for me to Export my Public key, but the ledger is still waiting for commands and doesn’t make the key available for export.

If I’m not mistaken this means I don’t have access to one of my wallets, or is there a way to restore it using the 24 words mnemonic and the 25th passphrase?

Any further ideas from the community welcome!

I shall explain the situation to the support teams of both products and see if they have a solution.

Cheers,
Dave

hmm, did u tried to delete the first wallet from daedalus before to restore the 2nd one?

So, another update,

I got around to deleting the first wallet as you suggested Alex, and there seems to be some progress.

Now with the second account Daedalus asks me to connect the Ledger device and enter my PIN, which I do and then it asks me to export my public key, which it hasn’t asked me to do before. I complete that action on the Ledger and the Daedalus states (in red print!) unable to detect you hardware wallet device. Disconnect and reconnect your hardware wallet to restart the process.

I am doing this after a restart, with no other apps running.

I have lodged a ticket with IOHK and Ledger but things are a bit slow there.

Cheers,
D

And some more Info,

I have just realised that the instructions on the Ledger when exporting the public key say “Acc #1…” and then the key.

I’m thinking I need a response from Ledger that show me how to send the public key for Acc #2.

Cheers,
D