My pool showed as UNKNOWN POOL in Yoroi

Hi There!

the delegator can find the pool in the wallet but once the delegation is done, the stake pool delegated section is showing the pool as UNKNOWN.
The pool TICKER is ADAPT, id: 780623d70c1168241e1d4d623e5e14e7f02e701b536329e9a735ad61

I also had issues on adapools, but after asking the team to refresh the info it started to show the ticker correctly.

Could you please help with that?
Thanks in advance!

If u go on, login then manage and metadata… do u see any errors?

It happened just for one delegator or for more?

BTW… 8 blocks in epoch 252? Huge performance


1 Like

Hi Alex!

just registered on this site - thanks for the info - I did not know about this pool managing - so very useful!
the result is what I expected:
Basic meta is valid.
Extended meta is valid.

Basically I have only 1 delegator - so, no much help on that front.

1 Like

actually I was very surprised with 8 blocks - made me confident that the pool settings is now probably ok. But still lot of things to do… glad that your pool is performing well

Yes, I received 3,2 M from IOHk for 3 month…
Epoch 252 I had 0 blocks assigned… then 253 7 … anyway… the protocol maintains the balance :wink:

I got a hint from IOHK team - when using wget I have problems with TLS to fetch the metadata:

--2021-03-22 21:48:57--
Resolving (
Connecting to (||:443... connected.
ERROR: cannot verify's certificate, issued by ‘CN=Sectigo RSA Domain Validation Secure Server CA,O=Sectigo Limited,L=Salford,ST=Greater Manchester,C=GB’:
  Unable to locally verify the issuer's authority.
To connect to insecurely, use `--no-check-certificate'.

I have to fix this first… I remember I asked to use the flag --no-check-certificate to list my node correctly… now I will ask them to remove that flag to able to determine others issue with metadata

My pool was fine in yoroi till today… now yoroi shows unknown pool … so… I don’t think there is something related with metadata (in my case)


Hi Alex. Did you fix this? I re-registered my pool yesterday after changing some metadata. Now yoroi says ‘unknown pool’ in the dashboard section. It’s shows ok in the delegation list tab.

Adapools says the metadata is valid.

Screen Shot 2021-03-25 at 11.17.05

I sow also today this issue, I went to delegation center, searched for my pool, clicked delegate even the button was not active, then I went back and refresh the dashboard session

1 Like

Hmmm… strange.

I withdrew my rewards and deregistered my stake key. I was able to then delegate to my pool again but it still says ‘unknown pool’.

no problem, I saw this issue on yoroi for my pool but everytime after few minutes or refresh was ok… anyway… this behavior will not affect your rewards

Is anyone else experiencing this?

I’ve also just tried removing the wallet then adding it again. Same problem. I know this doesn’t affect rewards but I am the SPO and this does not look good for my delegators.

I just noticed this as well. My pool, SUSHI, was showing up fine on Yoroi, but now it shows “Unknown Pool”. I didn’t do any registration changes. Was showing up fine last week on Yoroi. Is this a known issue with Yoroi currently?

Hi. I don’t know but I’d quite like it fixed. People delegating to my people are seeing ‘unknown pool’. This doesn’t look good and may put newbies off. I don’t know what to do about it though.

1 Like

Just following up, similar to Alex’s experience, I found that if I pull down to force refresh (mobile yoroi) several times, eventually it displayed my stake pool properly again. My guess is maybe Yoroi had some issues with their backend temporarily.

1 Like

Ah ok. I’m using the web browser version. I’ve tried removing the wallets and re-adding but it still shows ‘unknown pool’.

1 Like

I am having the same issue. In Yoroi mobile app a wallet delegated to my pool is showing as “Stake Pool Delegated: Unknown Pool” then my pool id.


  1. Meta data is all valid (via adapools dashboard).
  2. Meta data is showing in Daedalus (all fine in Daedalus)
  3. Tried forced refreshing yoroi screen lots of times (pull down the page in the app)

Not critical but be nice to fix as does not look great to appear as unknown pool.

At least it is not only my pool!


Refreshing more times… while he is in delegation dashboard should fix the issue

Refreshed about 30 times and not solving it.

Nothing is solving this for me either.