New Stakepool not in Blockchain!

I’m on step 13 of the Coin Cashew tutorial and an empty string was returned when I was instructed to verify it’s included in the blockchain! I received an ID but I cant find it in the blockchain! Please help, I don’t know what went wrong! Is there a period of time that you should wait after sending the transaction?


What is the Id?


I’m wondering if I put in the wrong port in the pool certification file, is that something can change without losing the money from the first transaction?

Edit- I double checked the port and it was correct

check this site - you can query useful infos about your pool:

if you made a successful transaction that means the fees of the transactions applied and no cancellation is possible

According to the site you sent me the biggest problem that it is having is it is unable to reach the relay node at the public address I entered into the pool.cert. Should I have entered the local IP? How do I remedy this?

yes - so the registration was successful - congrat!

First - should be reachable from outside - Have you opened the port in your firewall/router?

SWEET I’m glad that the registration worked, but now something is amiss.
I have configured port 6000 on the UFW and the router to be open.

so just checked you address on my machine:

netcat -zvn 6000
netcat: connect to port 6000 (tcp) failed: Connection timed out

Are you sure that this IP address is valid? - if it would be then I would get connection refused message… how did you determine your public IP address?

I determined that address using "".

you can check it from relay node with command line:

it returned

I don’t know if this is relevant but I just now used the to publish my relay node.

yes, that also should give you an error if port is not opened… what is the response? do you have logs of topologyUpdater?

I don’t know if I have any topology updater logs as I just ran it for the first time 5 minutes ago. I didn’t get an error when I ran


the log should be under the node logs folder with name topologyUpdater_lastresult.json

Apologies for the late reply, This is the output of the last result
{ “resultcode”: “201”, “datetime”:“2021-04-06 19:45:11”, “clientIp”: “”, “iptype”: 4, “msg”: “nice to meet you” }
{ “resultcode”: “504”, “datetime”:“2021-04-06 20:22:15”, “clientIp”: “”, “iptype”: 4, “msg”: “one request per hour please” }
{ “resultcode”: “203”, “datetime”:“2021-04-06 21:22:14”, “clientIp”: “”, “iptype”: 4, “msg”: “welcome to the topology” }

1 Like

This is strange…
you can check whether the port is open or not by using this site:
the relay node wont have incoming peers if the port is closed

It shows that the port is closed

I recommend to start a new topic with this issue…