Node won't process blocks after alonzo hfc event has errors

I watched as my node (1.29.0) successfully started reporting receiving alonzo blocks immediately after the alonzo hfc event relieved I went and had dinner. When I came back my node didn’t seem to be updating I looked at the logs and I saw an error

[ip-172-3:cardano.node.DnsSubscription:Error:848]^[[0m [2021-09-13 04:39:56.20 UTC] Domain: "relays-new.cardano-mainnet.iohk.io" Application Exception: 204.236.161.163:3001 InvalidBlock (At (Block {blockPointSlot = SlotNo 39917226, blockPointHash = 86314e3bfdad77863a73787b59ac72bb579f00fbfae73fb6347ccfa912584832})) (ValidationError (ExtValidationErrorLedger (HardForkLedgerErrorFromEra S (S (S (S (Z (WrapLedgerErr {unwrapLedgerErr = BBodyError (BlockTransitionError [ShelleyInAlonzoPredFail (LedgersFailure (LedgerFailure (UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (FeeTooSmallUTxO (Coin 2408636) (Coin 336139))))))),ShelleyInAlonzoPredFail (LedgersFailure (LedgerFailure (UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (FeeTooSmallUTxO (Coin 4287941) (Coin 406229)))))))])}))))))))

^[[33m[ip-172-3:cardano.node.ErrorPolicy:Warning:754]^[[0m [2021-09-13 04:39:56.20 UTC] IP 204.236.161.163:3001 ErrorPolicySuspendPeer (Just (ApplicationExceptionTrace (InvalidBlock (At (Block {blockPointSlot = SlotNo 39917226, blockPointHash = 86314e3bfdad77863a73787b59ac72bb579f00fbfae73fb6347ccfa912584832})) (ValidationError (ExtValidationErrorLedger (HardForkLedgerErrorFromEra S (S (S (S (Z (WrapLedgerErr {unwrapLedgerErr = BBodyError (BlockTransitionError [ShelleyInAlonzoPredFail (LedgersFailure (LedgerFailure (UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (FeeTooSmallUTxO (Coin 2408636) (Coin 336139))))))),ShelleyInAlonzoPredFail (LedgersFailure (LedgerFailure (UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (FeeTooSmallUTxO (Coin 4287941) (Coin 406229)))))))])}))))))))))) 200s 200s

I searched for a clue on this error and didn’t find anything that was helpful. I decided to make sure I had the most recent configuration files I found the latest mainnet-alonzo-genesis.json file and it was not the same the latest file contained a large new section called costModels and the old one didn’t I updated this and the mainnet-config.json and restarted the node. This now allows my node to not produce the above errors and it stays up to date.

Thought this could be helpful to someone.