Not listed yet on PoolTool

OK, I’ve heard the works about new pools not appearing on Daedalus, but we appeared there with no problem after our pool registration nearly 24 hours ago… and yet we’re still not listed on PoolTool.

The Pool ID derived from our cold.vkey has been visible in cardano-cli shelley query ledger-state --mainnet since that time, and I can see in that section of the ledger dump that our URL, relays, etc. all appear correctly. I had counted on that being all PoolTool would need to pick us up.

There are lots of suggestions to use the scripts at github:papacarp/pooltool.io but all except “buddies” look coded & dated back to the ITN period. There’s no indication on pooltool.io itself of what to do if “your” or someone else’s pool isn’t listed & it doesn’t have an offering to “claim your pool” in the profile of the account I created there.

Are we in a waiting period while our nodes generate enough information to be indexed? If not, what should be do to get into the listings, or to send information from our nodes?

Hi Robert,

pooltool will show registered pools near instantly - can you search and find your pool by id?

If you can find your pool by id, then there may be an issue with an inconsistency between the actual hash of hosted pool meta file and the meta hash provided when registering the pool

1 Like

What is the name and public key (in hex) of your pool?

Hi rphair,
Can you please check and make sure that your metadata hash matches with the hash you provided on your pool registration certificate.

Thanks @ADAfrog @erikd @SaadZoul for the responses. I went to bed about 24 hours after pool creation and it still hadn’t shown up yet. Upon getting back to work this morning, it’s listed (COSD) and searchable from both its name and its ID.

I did indeed check the metadata hash before registration & again before posting this. I’m glad this problem “went away” but from our experience it seems we should be prepared for additions or changes to registrations taking 24 to 36 hours to appear in PoolTool.

Just one more question: is there anything further that would help establish the relationship between the pool and the PoolTool account? The suggestion to “claim your pool” appears obsoleted by the witnessed ownership provided in the Shelley pool registration itself. But please let me know if any further action is suggested :pray:

[One more possibility is that somehow the result was cached in my browser (Firefox Linux). I’d previously looked for COSD to see if our name was used and it could have cached the negative result. It would be hard to reproduce that condition without knowing another pool that was about to be created.]

3 Likes

Papa Carp may be working on more secure ways to validate a pooltool account’s ability to claim pools - pooltool is a work in progress with much to do now that we have entered mainnet

3 Likes

FYI just today, perhaps only the the last couple of hours, something that I noticed just now: we now have a Manage tab on our pool page, which had a button Claim Your Pool which folds out into a nice data entry screen. I still haven’t figured out how it knows the pool is “mine” or whether it offers that Manage tab to all unclaimed pools.

It offers it to all unclaimed pools I believe. It may be you did not have the option before as perhaps you were not logged in.

@ADAfrog that certainly sounds like a convenient answer, but I assure everyone I’ve been logged in continuously and the earliest the Manage tab could have appeared there is 4 hours ago, around 2¾ days after our pool registration transaction was submitted. I can confirm this based on perhaps 100 visits to that site and 40 visits to our pool page in the last 3 days.

As always I appreciate your input but as far as I can see, PoolTool has some built in time delays both for pool appearance and then later the Manage tab for the supplementary data. I would have been visiting even more times if I thought there was any chance someone else would have been able to “claim” the new pool.

I think it’s a great utility and I’m happy to live with all of this but I do think it would be nice eventually to have an FAQ page there about these things.

Thank you for your feedback.

I would lean more towards the feature not being available being attributed to papacarp adding / swapping features as opposed to delaying claiming of pools. There are often times when certain features are disabled to accommodate addition or modification to feature sets. A new version of dbsync was recently launched, so perhaps this may have been the reasoning.

I will leave it to @papa_carp to clarify as only he knows the answer here.

1 Like

@COSDpool I just noticed this thread was still not closed. I’m glad it got sorted out and you were able to claim your pool ok.

I agree, more FAQ’s and stuff would be useful on pooltool. Not sure if you have noticed or not, but I haven’t even had time to setup the About page or other basic links. Its a continual work in progress to get functionality back to where it was in the ITN days.

There are no built in delays related to viewing the pool or claiming it in pooltool so not sure what happened there. New pools get added within 30 seconds of when we see the block on the chain.

On the subject of FAQs, I have a few community members that submitted markdown to our gihub repository to help others use pooltool. If you are interested, you could start developing the FAQ and maintain it for us. In return you’ll get free publicity for your pool. :slight_smile:

2 Likes

thanks @papa_carp for the invitation & if I can come up with a means of documenting it I’d be happy to help: maybe a short page giving new pool owners an updated to-do checklist & telling them what to expect. In the meantime, while the functionality is still coming along, it seems its best description is itself. As soon as we appeared in the listings & then the Manage tab appeared, it did work mostly as we would have imagined. Much appreciate the tool & your response :sunglasses:

1 Like