Nothing being written to node log

Been running on testnet the last two weeks to try things out. Running from systemd and was able to log all the Notice-level messages by directing the standard output and error of systemd to the log file, and in the cardano config file the scKind was set to StdoutSK under setupScribes. Worked great. Decided to try the file rotation feature of scKind FileSK, so I now have the following configuration in the config json

“TurnOnLogging”: true,
“defaultBackends”: [
“KatipBK”
],
“defaultScribes”: [
[
“StdoutSK”,
“FileSK”
]
],
“hasEKG”: 12788,
“hasPrometheus”: [
“xxx.xxx.xxx.xxx”,
12798
],
“minSeverity”: “Notice”,

“rotation”: {
“rpKeepFilesNum”: 10,
“rpLogLimitBytes”: 5000000,
“rpMaxAgeHours”: 48
},
“setupBackends”: [
“KatipBK”
],
“setupScribes”: [
{
“scFormat”: “ScText”,
“scKind”: “FileSK”,
“scName”: “/home/arbest/src/cardano-node/logs/node.log”
}
]

But node.log is empty.

Cardano node (block producing log is running and an fuser of the log file shows the pid of the cardano-node process. I’ve tried this both with the systemd control file having StandardOutput/Error pointing to the same node.log file, and without the StandardOutput/Error defined in the control file. Any ideas on what may be preventing the logging from showing up? Couldn’t find anything at docs.cardano.org or other forums

lrwxrwxrwx 1 arbest arbest 23 May 13 01:57 node.log → node-20210513015711.log
-rw-r–r-- 1 arbest arbest 0 May 13 01:57 node-20210513015711.log

arbest@g-2vcpu-8gb-nyc3-01:~/src/cardano-node/logs$ fuser node-20210513015711.log
/home/arbest/src/cardano-node/logs/node-20210513015711.log: 3367

Hi!
Should be:

"defaultScribes": [
    [
      "FileSK",
      "/home/arbest/src/cardano-node/logs/node.log"
    ]
  ],

Thanks! That worked. The instructions at Configuring Logging — cardano-node Documentation 1.0.0 documentation weren’t that clear

1 Like