Problem connecting - solution (for me)


#1

I was getting a very consistent “connecting to network” forever. I ran through a bunch of what people suggested (time/date settings on my mac, removing a lock file, purging log files, etc etc). Nothing seemed to work. I also want to note I am based in Bangkok, Thailand on a Fiber AIS connection. I happened to have my VPN running which puts me in Phoenix, Arizona, and the wallet connected and synced without a problem. I ran through several trials both with and without the VPN connected. It would work perfectly every time I had the VPN up and never seemed to connect with my normal Thailand based connection.

Just in case a dev is aware of any sort of filtering or refusing connections from certain places, etc.


#2

VPN worked for me!

I’ve been using Daedalus wallet for quite a while with consistent connections. No problems at all! Then just over the past several days I have NOT been able to successfully connect with Daedalus. I ran through the suggested fixes on the Daedalus FAQ with no positive results.

While searching solutions for the Connecting to Network problem I found this post about VPN. I started my VPN and launched Daedalus.

Success! Daedalus launched, connected and was up fully within a minute or two. I then experimented with my VPN connections. On, off, and different locations.

Final results. VPN on = Daedalus Success. Every time!

Thanks for discovery!