Problem in hosting poolMetaData.json

Hi All
Following in CoinCashew on How to upload poolMetaData.json to Github to register my stake pool, I am having hard time understanding on how 1. to shorten the URL less than 64 Char… and 2nd how to use tinyurl URL --metadata -url in stakepool registration transaction.

Because of the above issue wget fails with the following
~/cardano-my-node$ wget -O poolMetaData.json
–2021-09-01 20:04:15--
Resolving (…,,, …
Connecting to (||:443… connected.
HTTP request sent, awaiting response… 404 Not Found
2021-09-01 20:04:15 ERROR 404: Not Found.

Can some one please help. Thank you


Hi there, I’m far from an expert on this (I loaded my meta data to my own website) but did you try the link that is included in the CoinCashew instructions (How to upload poolMetaData.json to Github - CoinCashew)? I tested this on their example URL and it seemed to work just fine, taking the initial URL of and generating the shortened version of Both links give the same json output. Then I would guess that you use this shortened URL in the stake-pool registration-certificate command at the line --metadata-url \ in step 12 of the CoinCashew guide. Please note, the shortening link only works on a URL - hope this can be of some help, Somon

1 Like

Thank you for your reply Somon. Yes I followed line by line on CoinCashew upload .josn on Github. And I entered a valid data in my poolMetaData.json. I copied the Raw data which is: and shorten it to and used the shorten url as suggested.
In CoinCashew 10.Use this tinyurl URL --metadata-url in your stakepool registration transaction. I did not do anything moved to 11. Download your json with wget from your url (which is https://git/io/CaSPO) that is where I get the HTTP request sent, awaiting response… 404 Not Found
2021-09-01 20:04:15 ERROR 404: Not Found.

Hi, I just tried to shorten your URL and got a different tiny URL →

Both appear to give the same json output

And I just tried the wget from my terminal and I can retrieve your metadata →

$ wget -O poolMetaData.json

Gives the following output
$ cat poolMetaData.json
“name”: “SimbaPool”,
“description”: “Secured, reliable with high availability and performance stake pool.”,
“ticker”: “CaSPO”,
“homepage”: “

hi Somon, So how did you manage to shorten the URL and able to create or able to fined the tiny URL

Thank you so much Soman, I am able to generate the shorten URL.


Hi, I just used the link here

So glad that you can now generate & use the tiny URL



Hi Somon,
I am still trying to register, did upgrade to 1.29 now I am getting syntax error ever-time I try to run CoinCashew 12. Register your stake pooluse IP based relays, 1 entry per IP address

cardano-cli stake-pool registration-certificate
–pool-relay-port 6000
–pool-relay-port 6000
I enter my valid IP address since I have one I use only the top three commands. I tried it with < bracket> I tryed without bracket, tried with “x” and single ’ x’ none works. Can you please shade some light. Thank you

Hi, sorry, I’ve been absent for a while & I didn’t see your message. Could you please send me the error message that you are getting? Thanks

hi thanks here is the error
Get a portion of the current UTxO: by tx in, by address or the whole.
simba@yangudi:~/cardano-my-node$ Command failed: transaction build-raw Error: Transaction validaton error: Negative quantity (-2178701) in transaction output: TxOutInAnyEra MaryEra (TxOut (AddressInEra (ShelleyAddressInEra ShelleyBasedEraMary)Command failed:

Hi there, from what I understand, you are on step 12 of the CoinCashew guide, correct? For the registration transaction, you need to run the following transaction on your air-gapped machine. Imagine that you had two relay nodes, one with IP address & the second relay node with IP address 987.65.43.21. The IP addresses are added in as is, no “x”, no ‘x’, no angular brackets . If you’ve been following the guide, then all of the variables should already be set-up for you. You will also have to customise the pool-pledge, pool-cost & pool-margin entries to your specific values. You have to run the full transaction below & then copy the pool.cert file that this transaction makes to your producer node. Does this make sense? Don’t hesitate to come back to me if you have further questions, I will try my best to help, Simon

cardano-cli stake-pool registration-certificate
–cold-verification-key-file $HOME/cold-keys/node.vkey
–vrf-verification-key-file vrf.vkey
–pool-pledge 100000000
–pool-cost 345000000
–pool-margin 0.15
–pool-reward-account-verification-key-file stake.vkey
–pool-owner-stake-verification-key-file stake.vkey
–pool-relay-port 6000
–pool-relay-ipv4 \
–pool-relay-port 6000
–pool-relay-ipv4 987.65.43.21 \
–metadata-hash $(cat poolMetaDataHash.txt)
–out-file pool.cert

Please note, my copy-paste is not copying correctly in the transaction - please note the following:

  • every line, except the very last one, should end with a \ character, I don’t know why this isn’t always copied
  • for the input value --metadata-url, you need to add in the url in which you loaded the metadata. For example, for my website, the entry would be:
    –metadat-url \