Processed TX is stuck at 0?

I re-created my block node and tried to update the node.cert following this tutorial Guide: How to build a Cardano Stake Pool - CoinCashew, but now my Processed TX is stuck at 0… Why?

“First the node should be 100% sync, after that the topologyupdater should run for 4 times and after that you should see tx incrementing…” - source

Guess I’ll wait then…

Also just realised my relay node is using a different port and I need to port foward the new port as well.

Do not run the topology updater on Producer… check the TX on Relay, should be 0 as well

:+1: Yes I know. Just showed the screenshot from my block producer, but not to worry, it’s relay doing the updater. (Yup relay showing 0 as well)

1 Like

I believe by default TraceMemPool is set to false in mainnet-config.json. You will have to set TraceMemPool:true to see the Processed TX and Mempool TX/Bytes values.

Like in our case, all our nodes, BP and Multiple Relays have 16GB RAM. So if you have 16GB RAM then your pool should run smoothly with TraceMemPool set to true.

I’ve heard from some pool operators that you can set TraceMemPool to false on relays but set it to true on BP so you can see the TX values incrementing/changing since your BP only talks to your relay, if it doesn’t increment then its could be a Firewall issue. Thanks,

I do have traceMempool set to true for both relay and block, so it’s most likely the updater needing to do its thing. I’ll wait overnight and update here what the status is with this problem.

But thanks for the heads up about the traceMempool config. I’ll keep that in mind in the future!

Yay, it works now! I have one incoming connection (other than my block node) and now my processed TX is working.

1 Like