Processed TX question

Dear all, Good day. I have a question. Processed TX is 0 for a few days. That means I am doing something wrong? I checked everything and seem fine. I am using testnet at the moment.


Thank you.

IN peers 0, NOT OK

How many relays do u have? Did u connected the relays to the Produce

I have 4 relays. 1 other virtual machine and 3 from the testnet website

so, your Producer is connected to the Relay but the relay is not connected to the Producer… how is the glive for relay?

It is the same. I have only 1 peer there, the block producer.3333

Seems like some issue with the topology configuration. Maybe paste both configs here. You can mask your server IPs if needed. Just mark which config belongs to which node.

Dear sir, This is a testnet, so its okay. Here you can find all the info. Let me know if i have something wrong configured.

for relay is not ok, you will need to run topology updater script to announce your relays to the public networks… otherwise other nodes will not connect to your relays and you will not make part to the blockchain = no processed TX

you have the scripts inside the coincashew guides, also be aware that you will need to use magic number for testnet

Note related to TX 0 problem:
One of the goals is to have the block producer node isolated and reachable only from the relay(s). So BP should actually connect just to your relay(s). Relay(s) should connect to BP and other relays in the network. Optimally the firewall should be configured to not allow other connections.

Dear @Alexd1985 and dear @mcrio ,

I have followed your advises, and I have left the nodes to work for a few days to see if the TX will not be 0.

I have run the updater script on the relay node, and also changed the topology accordingly.

But TX are still at 0. Please take a look on the screenshots.

Is something wrong with the ports?
Thank you very much.

You don’t have IN peers (other than your Producer) check the last logs for topology updater… what is the message received?

Dear Alex,

Thank you for your prompt reply.
Please find below the message:

See… u must run the topologyUpdater script once/hour… all time (set on crontab to run each hour)

U must see “glade u are staying with us!” message

The command I have followed from coincashew guide is:

cat > $NODE_HOME/crontab-fragment.txt << EOF

33 * * * * ${NODE_HOME}/


crontab -l | cat - ${NODE_HOME}/crontab-fragment.txt > ${NODE_HOME}/crontab.txt && crontab ${NODE_HOME}/crontab.txt

rm ${NODE_HOME}/crontab-fragment.txt


This means it must run each hour min 33 but it ran?

I do not know. How can i check which logs?

Now it gives me an error that only once per hour i can run it.

Exactly, once per hour… u should see inside the logs folder… u should have a file log for topology updater… check inside if it ran

Once i tried now to run it again it gave me this error:

“msg”: “glad you want to stay with us, but please check and enable your IP:port reachability”

See, now it’s telling u that u have an issue with the port 6000
U must open the port to alllow connections from any… if u have a private lan perhaps u will need a port forward on your local router to map the all extern connections to port 6000 → intern relay IP port 6000

Dear Alex,

I have a private network. I have opened the ports 6000, 6001, 3001 but the issue still the same.