Registered pool but not shown in Daedalus

So what you need is a public IP or a domain name of your node.
where did you setup your pool? in cloud, or it is your own machine

Cnode hostname… delete the IP and leave it default

Cheers,

Sorry I reached the maximum replies cap.

The pool is on my machine. Yesterday I did the re-registration process with a public ip this time.
I left the default env for the topologyUpdater.sh, but i still don’t see my relay registered correctly.
I’m visible also in adapool but it appears offline.
In the mainnet-topology.json i left the private ips because i let communicate relay and block producer with them.
In pool.vet i still see the old private IP.

What am I doing wrong?
Failed Re-registration?

send the registration cert with the public IP of the relay (or dns name)

Cheers,

Thank you all, I think i made it…now at least i see a public ip interogating the pool from pool.vet.
Also, it appeared on the daedalus wallet for a brief moment before i tried the re-registration.
Gotta study more, now i’m setting up the relay-topology_pull.sh script.

Good work everybody

1 Like

You need to make sure the relay is accepting connections from outside, because it’s not reachable. If it’s behind a router, check port forwarding. Also make sure to fix the topology file, so that it can connect to other peers.

Is it possible to move this thread to the right section of the forum?

Hi, thank you.
I’ve registered the node with the public ip. The relay is already port forwarded on port 6000, but maybe something is wrong with the registration in the topology, it is not shown on the topology.json yet…

I tried to move this thread but i could not be able to do it, in which section should be in?

There is a “Setup a stake pool” sub forum under the Staking&Delegation section. You may not be able to move it because they put some limitations about the posting permissions on the technical sections. Ask one of the mods to do it.

1 Like

use pool.vet to check the status of the nodes

Ok guys, the problem i had were related about 2 main things.

  1. i had not a public IP, the IP submitted for registration was the one behind my ISP NAT. I had to contact my ISP to obtain a public IP, now I’m doing the registation again. The port is now open checking via Open Port Check Tool - Test Port Forwarding on Your Router.

  2. at first my metadata.json wasn’t matching with his hash, so i sugged to do a double check when you shrink your metadata.json url from the repo.

Thank you very much for the support

1 Like