Stakepools registered after mine are showing up in Daedelus

I posted yesterday because I registered my pool on 4/9/21 and it wasn’t showing up in Daedelus. Everything is setup correctly with no errors. I was looking around today and I’m seeing numerous other pools that were registered yesterday 4/11/21 and showing up in Daedelus, but mine is not yet listed. Any idea what would cause this?


Another Pool registered two days after mine that’s in Daedelus:

Here’s my pool registration on 4/9.

Whenever this happens the usual recommendation is to simply re-register the pool. You’ll pay another tx fee (~.17 ada or so).

1 Like

Thanks for the response and I can certainly try a third registration. However, do we know if this is a bug? If so, has it been reported and is there a link?

It’s not a bug in the blockchain, but it could be some issue in Daeldalus. Have you checked other wallets and other pool sites like pooltool or adapools or in Yoroi? How do those look?

I’ve checked other pool sites and my pool shows up. I was told to wait, but when I saw other pools registered after mine showing up in Daedelus, that’s when I realized something was up. Adapools (Daedelus View) Shows my pool listed, but it’s not.

So normally I’d blame the thing displaying the pool data, but since Daedalus is using a local node, I’d guess that somethings is off there. Have you tried restarting the app or even rebooting your computer?

I did just to make sure Daedelus wasn’t bugging out, but still not showing up. Also had a friend verify he’s still not seeing it in Daedelus either.

Hmm well the only thing remaining to do is to re-submit your pool registration again and then check again.

Done! Updated cert is there, adapools shows the updated cert and poolvet is all green, no warnings or errors. I guess we’ll wait and see.