Resolve Connection Issues After Latest Updates | IOHK Note to Users

daedalus

#1

Connection Issues After Recent Cardano & Daedalus Update


After installing the latest Daedalus 0.10.0 and Cardano 1.2 release delivered to users through the Daedalus update system, some users have reported an issue with connecting to the network.

An analysis of the logs received from the submitted support requests shows that the cause of the issue is corrupted configuration caused by the installation of the update while Daedalus processes were still running.

This occurred if users interrupted the normal update installation process by clicking on the Daedalus icon while the update system was shutting down Daedalus processes, after the user has accepted the update in Daedalus user interface.

To avoid this issue in the future, the Daedalus installer will be fixed with checks for running Daedalus processes before starting installation.

This fix will be shipped to the users as the 1.2.1 hotfix release.

Users experiencing the issue described above should do the following:

  1. Restart their computer
  2. Download the Daedalus installer from the Daedalus website
  3. Install Daedalus by executing the downloaded installer

After the installation is complete, Daedalus should work as expected and all wallets should be visible in the user interface.


Connection being refused- Endless "Connecting to the network"
#2

When will the hotfix be released?


#3

The issue is related only to the automatic update. You can fix it, if you experience that issue, by upgrading Daedalus manually. It wont affect your existing wallets.


#4

I tried everything in the FAQ and sent issue log from daedulus to support. Was just hoping with a hotfix it would be fixed


#5

I have the same problem, the wallet does not connect tried all the ways and without result. The link to download the wallet that is shown above does not work!


#6

Update: turns-out for me it was the “wallet” folder hanging-up the connection. Even a previous back-up of the two folders (secrets and wallet) failed to work, but swapping-out the previous wallet folders with the new folders created from a fresh installation enabled the connection and blockchain to catch-up after which the new wallet screen appeared. In the process now of restoring, the correct amount immediately showed but the transaction history is taking forever. Goes to show wallet files alone cannot be counted on for a reliable back-up.

Original Post: Same here, and I noticed it connects with an entirely fresh daedalus folder going through the initial setup etc and proceeding to download but refuses to connect with the pre-existing folder.


#7

Tried this fix, didn’t fix the issue


#9

I found a fresh reinstall was needed but first renamed the original ,.roaming\daedalus to allow a completely fresh …roaming\daealus to be created at which point it connected which led me to the realization that something in the old roaming folding was jamming-up the download. At that point I quit the client, renamed the new …roaming\daedalus folder, moved everything but DB-1.0 out of the original roaming folder (for safe-keeping) then copied everything but DB-1.0 from the fresh roaming to the original roaming folder renamed back and re-started the client which connected and picked-up the blockchain sync in the original roaming folder from where it left off after which I was presented with the “Create Wallet” screen enabling the restore.


#10

Somebody can describe in detail the update of the wallet? I’ve tried all the options, nothing works, I don’t want to lose all my ADA. The purse is not as not connected and send the logs didn’t help, answer to my query about the problem I never received. Help to understand thoroughly in this, that as I am a beginner in this matter and do not understand much. Thank you!


#11

Manually this as ? I don’t understand, I’m new to all this. Can be detail. Thank you!


#12

Thank you very much, your method really works! Before I tried a lot, did not help until I tried to do as described in you and the miracle worked. Thanks again for the way !!!


#13

Just download the wallet from the official website and click on it.


#14

Glad I was able to help. What’s odd is a second client running on Window 10 upgraded without a hitch (the problem was on Windows 8.1) so I didn’t have to go through the laborious restoration on Win 10 however for future reference the restoration on Win 8.1 was sped-up using a tip posted by another community member


#15

I moved this post from “Developers” to “Community Technical Support

cc @IOHK_Kevin

:grinning:


#16

I did a complete new install on a new laptop. I did all of the steps in the FAQ regarding the " connecting to network error" it still doesn’t work on my new laptop. OS: Win 10Pro

This is error I get during connecting from the console:
emit @ events.js:197 renderer.js?407b:34 [14:36:34.515] AdaApi::syncProgress error: { "stack": "Error: connect ECONNREFUSED 127.0.0.1:8090\n at Object.exports._errnoException (util.js:1050:11)\n at exports._exceptionWithHostPort (util.js:1073:20)\n at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1097:14)", "message": "connect ECONNREFUSED 127.0.0.1:8090", "code": "ECONNREFUSED", "errno": "ECONNREFUSED", "syscall": "connect", "address": "127.0.0.1", "port": 8090 }

This is the log of the cardano-node.log

 [*production*:INFO:ThreadId 3] [2018-06-04 12:35:12.99 UTC] Allocating node resources...
[node:ERROR:ThreadId 3] [2018-06-04 12:35:13.01 UTC] logException: UnsuccessfulOperation "c_rocksdb_open" "IO error: Failed to create dir: ...\\Roaming\\Daedalus\\\\DB-1.0\\blocks\\index: No such file or directory"
cardano-node.exe: UnsuccessfulOperation "c_rocksdb_open" "IO error: Failed to create dir: ....\\Roaming\\Daedalus\\\\DB-1.0\\blocks\\index: No such file or directory"
cks\\index: No such file or directory"
cardano-node.exe: UnsuccessfulOperation "c_rocksdb_open" "IO error: Failed to create dir: ....\\AppData\\Roaming\\Daedalus\\\\DB-1.0\\blocks\\index: No such file or directory"

#17

Yes, I have been agonizing on this issue for couple of months. At times I leave the connecting
to 36 hours but nothing happened. So much worry and loss of confidence as there is nobody
I could call to talk and be helped with.

Thanks very much for this notice. Hope solutions will come in faster in the future as we cannot
confidently talk to others about Cardano positively with a glitch and worry in our mind.

Will try again.

Thanks and more power to us all.


#18

It seems you have an inconsistent DB-1.0 folder structure or some permission issue on the %appdata%\Daedalus\DB-1.0\blocks\index folder.

Delete or move it(move DB-1.0 DB-1.0.orig, but it uses a lot of space and you will need ~9GB more), but only if you have the 12-word mnemonic(s) phrase for restoring your wallet(s).

Daedalus, will recreate the whole DB-1.0 structure and will start syncing the blocks (~9GB), which takes time and could last for some hours.

It’s ~4hrs for me on a ~35Mb/s network.