Resubmitting stake data

Does this look right (from the coin cashew guide):

Im resubmitting my pool data after already paying my 500 ADA. Should I simply remove references to poolDeposit from the math to reflect only the transaction fee? see pic

image

I think it worked…still struggling why it reflected my margin changes, but not the ticker, name or website is blank.

Details, ur pool id? Did u changed the metadata file?

905317f5493afcc842f0a26aebac87491e3c76e7c1a8073c9ebcbb2f
Thanks for taking a look.

I updated the json file with new ticker and name. I hashed it, Uploaded it to git, rebuilt the cert, built another signed transaction and submitted it. The transaction submitted fine because my margin modification reflected on pooltool.io

So guessing something is up with the JSON being read, That should be fast to process right?

I don’t see any issues with metadata

https://smash.cardano-mainnet.iohk.io/api/v1/errors/905317f5493afcc842f0a26aebac87491e3c76e7c1a8073c9ebcbb2f

U should wait a little bit more… perhaps synch issues due to transition to the new epoch

Question: before to modify the margin… the ticker was visible?

No it never worked. Found that my first submission was duplicate ticker with an existing so thought maybe that was why but I guess not now. The pool sites always had the ID though from the start. just no meta.

But perhaps it didn’t take the metadata file when u tried to register?
How it looks on ur node?

The contents of it:

cat poolMetaData.json
{
“name”: “TheDogePool”,
“description”: “For those who want to branch out”,
“ticker”: “1DOGE”,
“homepage”: “https://gamerpool.website2.me/
}

And u extracted the correct metadata hash and inserted into the registration certificat right?

cardano-cli stake-pool metadata-hash --pool-metadata-file pool_Metadata.json

Yeah I pipe it out to a file. Then on cold machine I specify it as one of the pieces in the cert generation:

cardano-cli stake-pool registration-certificate
……
–metadata-url Pool/poolMetaData.json at main · applesmash/Pool · GitHub
–metadata-hash $(cat poolMetaDataHash.txt)
–out-file pool.cert

Then sync issues… now it’s showing :slight_smile:

Thanks for the help. You said now it’s showing? I still see the info missing on ADAPools. Or are you saying it probably needs more time?

image

I thought is this:

sorry,

Hey David, can you give some guidance on how you did it? I’m trying to do the same thing and getting this funky error:

Shelley command failed: transaction submit Error: Error while submitting tx: ApplyTxError [LedgerFailure (UtxowFailure (UtxoFailure (ValueNotConservedUTxO (DeltaCoin 2096421302) (DeltaCoin 2596421302))))]

I had a similar error at one point. I had changed the pool pledge and pool stake when generating pool.cert. I’m pretty sure that why it threw that error. Make sure those values are the same as the original and see if it works.

Unfortunately still doing it even though i regenerated the pool.cert with the same info. Real frustrating.

In case anyone else has this issue regarding the metadata not showing I figured it out, doing a wget to the file on github shows that github pads the file with HTML “stuff” - so of course the hash didnt match.

I hit the raw file button in github, used that link, hashed and resubmitted and everything looks good now. Thanks @Alexd1985 for validating my sanity above.

1 Like

I am rather new to this. How did you (re)hash? I seem to get a hash mismatch on my pool.

Hi,

My process is this:

  1. upload new metadata to wherever it will reside.
  2. download it to your node using wget.
  3. inspect the download to see if your hosting padded it with garbage. If so figure out why and make it not happen. Github will do this if you don’t use the “Raw” button and use that URL.
  4. If the download looks right, run the cardano hash function: cardano-cli stake-pool metadata-hash --pool-metadata-file poolMetaData.json
    Then make sure you use the output of that in your next submission to the network.

I used the coin cashew guide to set mine up. check that out if you aren’t already using it.

Here is a pic of what I mean with Github: image

1 Like

Thanks for the response! Github wasn’t working for me so I switched to another host. I will keep this in mind when/ if I go back to Github (more convenient).

1 Like