Segmentation fault (core dumped)

The node will be running fine synching with the network but after extending the chain for a bit it exits with “Segmentation fault (core dumped)”

I’m trying out the testnet on a Rasberry Pi 4 (which is definitely an uphill battle), 8GB ram.
Running Ubuntu Aarch64. I’m using the latest build 1.25.1 with the lastest testnet-topology, host-addr, and the latest testnet-config.
Cardano-node was built with cabal- and ghc-8.6.5 (just a combination that worked on Rasberry Pi)

Digging around on the forum, it had been reported before Here on an older build.

Any help or additional debugging steps would be appreciated!

As an update, it seems that occasionally it could also simply stop responding altogether without exiting with the “segmentation fault” error message. Computer isn’t frozen and other generic commands can be executed, but cardano related commands like “cardano-cli shelley query tip --testnet-magic 10979110” also will be unresponsive.

1 Like

Okay, I think I’ll consider this as solved.

I ended up downloading pre-built versions of cardano-node and cardano-cli from pi-pool, replacing the ones I built and it had been smooth sailing.

Guess that even if the system lets you build the node and client, it doesn’t guarantee they’re built correctly!

1 Like